Bug 1340075 - "could not obtain a database connection within 5.000 seconds (waited 5.000 seconds)" when running automate scripts
Summary: "could not obtain a database connection within 5.000 seconds (waited 5.000 se...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.5.5
Assignee: mkanoor
QA Contact: Milan Falešník
URL:
Whiteboard:
Depends On: 1334909
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 12:13 UTC by John Prause
Modified: 2017-08-30 01:37 UTC (History)
6 users (show)

Fixed In Version: 5.5.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1334909
Environment:
Last Closed: 2016-07-26 15:34:59 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 2 CFME Bot 2016-06-14 18:56:49 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=0bebd665f19863f6a8df6a9e44ef84858bcba1ed

commit 0bebd665f19863f6a8df6a9e44ef84858bcba1ed
Merge: 5c117ff 2f7d9f4
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Jun 14 14:53:15 2016 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Jun 14 14:53:15 2016 -0400

    Merge branch 'bugzilla_1340075_5_5_z' into '5.5.z'
    
    Wrap ar_method around Database calls
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1340075
    
    ar_method is responsible for releasing the connection to the database.
    It wasn't being called when creating tags and categories and also when
    checking for their existence.
    
    Clean Cherry Pick from https://github.com/ManageIQ/manageiq/pull/8669
    
    See merge request !967

Comment 4 Milan Falešník 2016-07-15 08:06:52 UTC
Checked in 5.5.5.2.

I ran the reproducer script from the parent bug about 10 times and no error happened. Tags were copied as expected.

Comment 6 errata-xmlrpc 2016-07-26 15:34:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.