Bug 1340078 - libXfixes-5.0.2 is available
Summary: libXfixes-5.0.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libXfixes
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Tissoires
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 12:15 UTC by Upstream Release Monitoring
Modified: 2016-05-28 18:33 UTC (History)
3 users (show)

Fixed In Version: libXfixes-5.0.2-2.fc24
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-28 18:33:44 UTC
Type: ---


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (16.30 KB, patch)
2016-05-26 12:15 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2016-05-26 12:15:08 UTC
Latest upstream release: 5.0.2
Current version/release in rawhide: 5.0.1-6.fc24
URL: http://xorg.freedesktop.org/archive/individual/lib/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1775/

Comment 1 Upstream Release Monitoring 2016-05-26 12:15:23 UTC
Patching or scratch build for libXfixes-5.0.1 failed.

Comment 2 Upstream Release Monitoring 2016-05-26 12:15:25 UTC
Created attachment 1161963 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.

Comment 3 Upstream Release Monitoring 2016-05-26 12:15:26 UTC
Patches were not touched. All were applied properly

Comment 4 Upstream Release Monitoring 2016-05-27 07:38:42 UTC
bentiss's libXfixes-5.0.2-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=768749

Comment 5 Fedora Update System 2016-05-27 08:54:44 UTC
libXfixes-5.0.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-88baa4e5ce

Comment 6 Fedora Update System 2016-05-28 03:25:59 UTC
libXfixes-5.0.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-88baa4e5ce

Comment 7 Christian Stadelmann 2016-05-28 15:03:14 UTC
This update seems to break at-spi on wayland:


Successfully activated service 'org.a11y.atspi.Registry'
SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
** (at-spi2-registryd:26015): WARNING **: AT-SPI: Cannot open default display
** (yumex-dnf-updatechecker:16295): WARNING **: AT-SPI: Could not obtain desktop path or name
** (gnome-settings-daemon:16158): WARNING **: AT-SPI: Could not obtain desktop path or name
** (evolution-alarm-notify:16251): WARNING **: AT-SPI: Could not obtain desktop path or name
** (transmission-gtk:16274): WARNING **: AT-SPI: Could not obtain desktop path or name
** (gnome-calendar:22924): WARNING **: AT-SPI: Could not obtain desktop path or name
** (gnome-terminal-server:22404): WARNING **: AT-SPI: Could not obtain desktop path or name Activating service name='org.a11y.atspi.Registry
 ** (at-spi2-registryd:26017): WARNING **: Could not open X display

It seems like every single Gtk+ application starting in a gnome+wayland session is printing 10…20 of those messages. Please don't spam my syslog ;)

Comment 8 Benjamin Tissoires 2016-05-28 15:23:06 UTC
(In reply to Christian Stadelmann from comment #7)
> It seems like every single Gtk+ application starting in a gnome+wayland
> session is printing 10…20 of those messages. Please don't spam my syslog ;)

I am very surprised this to be the case. The difference between 5.0.1-6 and 5.0.2-2 is basically just a tag upstream of the new release after a removal of a compatibility function that was here to fix a CVE in libX11 < 1.6.

Could you downgrade just libXfixes to 5.0.1-6 and see if the problem persists?

Comment 9 Christian Stadelmann 2016-05-28 16:07:15 UTC
(In reply to Benjamin Tissoires from comment #8)
> (In reply to Christian Stadelmann from comment #7)
> > It seems like every single Gtk+ application starting in a gnome+wayland
> > session is printing 10…20 of those messages. Please don't spam my syslog ;)
> 
> I am very surprised this to be the case. The difference between 5.0.1-6 and
> 5.0.2-2 is basically just a tag upstream of the new release after a removal
> of a compatibility function that was here to fix a CVE in libX11 < 1.6.
> 
> Could you downgrade just libXfixes to 5.0.1-6 and see if the problem
> persists?

I did, and the problem went away. This is why I left this comment.

Now I upgraded again and the issue isn't coming back, so probably this was a false alert. Sorry for the noise.

Comment 10 Fedora Update System 2016-05-28 18:33:42 UTC
libXfixes-5.0.2-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.