Bug 134009 - memory ordering issue with ia32el
memory ordering issue with ia32el
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ia32el (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 18:47 EDT by Yoav Zach
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEL3-U8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 04:06:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yoav Zach 2004-09-28 18:47:13 EDT
Description of problem:
We would like to update you with a bug fix we have identified on the 
latest Btgeneric 5334 (ia32exec.bin) we have delivered you on Sep 
15th – targeted for EL3 U4 – 

Bug description: the translator maintains processor ordering 
compatibility of the source IA-32 application by either using 
affinity solution or using strong order version of the load/store IPF 
instructions ( acquire-release versions of the load / store 
instructions ).  We have identified a bug in one of the optimizations 
that in certain case the generated code did not use the acquire-
release versions of the instructions when it actually needed to. 

The bug was discovered during a code review – we have not seen 
failures in our test environment due to this bug – even on MP systems 
running stress testing - 

Bug fix: the fix was by eliminating the problematic optimization 

Although this bug did not duplicate on real tests, we still highly 
recommend the fix




Version-Release number of selected component (if applicable):
5334
Comment 1 Yoav Zach 2004-09-28 19:32:20 EDT
i tried to attach the binary with the fix, but its size exceeds the 
limit. we sent the binary thru email to bennet@redhat.com and 
sdenham@redhat.com on Sep 28. Please let me know if it was not 
recevied.
Comment 2 Susan Denham 2004-09-29 18:31:25 EDT
We did receive the new binary; thanks.  We are requesting that Intel
shoulder the testing effort with this new binary (as with previous
ones!).  In particular, we request that you perform benchmark tests as
well as gcc, glibc, and mozilla-type tests.  

Elena Zannoni has already spoken to Geoff Gustafson, Intel engineer
onsite at RH, about testing; Geoff can repeat some of the simpler
testing that we we (with gdb and a simple ia32 program (break main;
run) but can't go too far beyond that.  

We've posted the latest rpms (ia32el-1.1-3 in dist-4E-lacd and
ia32el-1.1-2.EL3 in dist-3.0E-lacd-U4) at the following locations:

partners.redhat.com/6fc892da0b7d82b0ae10ab220aecd7b8/RHEL4-ia32el

and

partners.redhat.com/6fc892da0b7d82b0ae10ab220aecd7b8/RHEL3-ia32el

Please grab these rpms and test as rigorously as possible by next
Wednesday, 6 October.  We're quickly approaching RHEL 4 Beta 2 package
freezee and need to ensure that testing is done ASAP.  Many thanks.
Comment 3 Jakub Jelinek 2004-10-28 04:19:40 EDT
Latest packages are now ia32el-1.1-6.EL3 (for RHEL3 U4 lacd) and
ia32el-1.1-7 (for RHEL4 lacd).
Comment 4 Elena Zannoni 2006-08-08 10:55:13 EDT
Can we close this bug?
Comment 5 Petr Machata 2006-08-09 04:06:32 EDT
Yes, I'm closing it.

Note You need to log in before you can comment on or make changes to this bug.