Bug 1340142 - syncing cluster state
Summary: syncing cluster state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: unclassified
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 2
Assignee: Shubhendu Tripathi
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-26 14:02 UTC by Lubos Trilety
Modified: 2016-08-23 19:52 UTC (History)
3 users (show)

Fixed In Version: rhscon-core-0.0.26-1.el7scon.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 279279 None None None 2016-06-08 06:29:09 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-05-26 14:02:00 UTC
Description of problem:
After some time cluster state is switched to syncing (state: 4 in mongodb) and it never changes back to some proper state.

There's this line in skyring.log:
sync.go:60 SyncClusterDetails] skyring:1e27f6b9-f1a9-4ce4-9149-3265e2126654-Cluster ceph is not in active state. Skipping sync.

But the cluster is active. When the state is changed manually in mongodb everything seems to work. Pools can be created etc.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.19-1.el7scon.x86_64
rhscon-ceph-0.0.18-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create some cluster
2. Restart skyring service
3.

Actual results:
Cluster has a syncing state. Pool cannot be created because it says that cluster is not active.


Expected results:
Cluster state will change after some time to failed/warning/ok

Additional info:

Comment 1 Shubhendu Tripathi 2016-06-07 05:03:15 UTC
@Lubos, is it like cluster remains in syncing state forever. I dont think so. I am having patch https://review.gerrithub.io/#/c/279279/ to make sure cluster is moved back to active state, if syncing fails at any stage.
Hope this would solve the issue.

Comment 2 Lubos Trilety 2016-08-03 09:09:07 UTC
We don't see that in last several weeks.
The latest build which we use:
rhscon-core-0.0.38-1.el7scon.x86_64
rhscon-ceph-0.0.38-1.el7scon.x86_64
rhscon-core-selinux-0.0.38-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch

If the issue appears again the BZ will be re-opened.

Comment 4 errata-xmlrpc 2016-08-23 19:52:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.