Bug 1340153 - migration broken: Elasticsearch config does not include admin permissions
Summary: migration broken: Elasticsearch config does not include admin permissions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: chunchen
URL:
Whiteboard:
: 1340376 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 14:35 UTC by Luke Meyer
Modified: 2016-09-30 02:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-31 19:26:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1187 0 normal SHIPPED_LIVE Red Hat OpenShift Enterprise logging-elasticsearch image bug fix update 2016-05-31 23:26:12 UTC

Description Luke Meyer 2016-05-26 14:35:05 UTC
Description of problem:
When running the v3.2 deployer with MODE=migrate, the migration fails because the admin user doesn't have the correct permissions.

Version-Release number of selected component (if applicable):
logging-elasticsearch:3.2.0-8

Steps to Reproduce:
1. Install version 3.1
2. Create some project logs
3. Upgrade to version 3.2.0 per https://docs.openshift.com/enterprise/3.2/install_config/upgrading/manual_upgrades.html#manual-upgrading-efk-logging-stack including the migration

Actual results:
Migration fails with:
++ curl -s --cacert /etc/deploy/admin-ca.crt --key /etc/deploy/admin-key.key --cert /etc/deploy/admin-cert.crt -XPOST https://logging-es:9200/_aliases -d '{ "actions": [ { "add": { "index": "foo.*", "alias": "foo.f87ec39c-21ba-11e6-9d12-005056ab75a6.reference"}} ] }'
Migration for project foo: {"error":"RuntimeException[com.floragunn.searchguard.tokeneval.MalformedConfigurationException: no bypass or execute filters at all]; nested: MalformedConfigurationException[no bypass or execute filters at all]; ","status":500}

Expected results:
Migration succeeds

Additional info:
We put the right config into the 3.1.1 image but somehow neglected to include it in the 3.2.0 image. A workaround might be to edit the elasticsearch DeploymentConfigs triggers and point them at version tag 3.1.1 for now, since there is no (other) difference between the two images.

Comment 4 errata-xmlrpc 2016-05-31 19:26:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1187

Comment 5 Luke Meyer 2016-06-03 14:10:54 UTC
*** Bug 1340376 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.