Bug 134016 - Loading usb modules in rc.sysinit causes repetitve rebooting
Loading usb modules in rc.sysinit causes repetitve rebooting
Status: CLOSED DUPLICATE of bug 132719
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 19:36 EDT by Larry Bartash
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Bartash 2004-09-28 19:36:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040926
Firefox/0.10

Description of problem:
# Everything else (duck and cover)
for module in $other ; do
       modprobe $module >/dev/null 2>&1
done

In the section above in rc.sysinit, the modprobing of usb modules at
this stage works fine. However, after the system has booted
completely, before you can even login, the system reboots. It then
happens over and over again, until you boot with a rescue disk and
comment this section out. If you comment them out, boot, then login.
Modprobing the usb modules does not cause system to reboot. System
runs fine. Is this a usb kernel module problem or something awry with
my particular motherboard? MSI motherboard MS-6728 (865PE Neo2 Rev1),
latest bios. Another devel system on a different motherboard does not
exhibit this behavior.

Version-Release number of selected component (if applicable):
initscripts-7.84-1

How reproducible:
Always

Steps to Reproduce:
1. yum update (gets new initscripts)
2. reboot
3. pray it works this time (hmm doesn't)
    

Actual Results:  Keeps rebooting before you can login.
Must boot with a rescue disk to comment out the section.
Keep the usb modules from loading.

Expected Results:  System should not reboot and everything should work
including the usb modules

Additional info:

This started happening long ago when the initscripts was first changed
to autoload the modules in rc.sysinit. This problem seems to have
begun when Rawhide began using udev, kernel 2.6.8 (currently
2.6.8-1.541), and changed initscripts.
Comment 1 Bill Nottingham 2004-09-28 21:12:03 EDT

*** This bug has been marked as a duplicate of 132719 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.