Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1340165 - "No Containerimage Conditions are defined ." is always shown after Container Image condition deleting
Summary: "No Containerimage Conditions are defined ." is always shown after Container ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: All
unspecified
low
Target Milestone: GA
: 5.6.0
Assignee: zakiva
QA Contact: Dmitry Misharov
URL:
Whiteboard: container:ui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 14:59 UTC by Dmitry Misharov
Modified: 2016-06-29 16:06 UTC (History)
9 users (show)

Fixed In Version: 5.6.0.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 16:06:28 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the bug (69.47 KB, image/png)
2016-05-26 14:59 UTC, Dmitry Misharov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Dmitry Misharov 2016-05-26 14:59:54 UTC
Created attachment 1162037 [details]
Screenshot of the bug

Description of problem:
"No Containerimage Conditions are defined ." message is always shown after Container Image condition deleting.

Version-Release number of selected component (if applicable):
5.6.0.8-rc1.20160524155303_f2a5a50 

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Control->Explorer.
2. Open Conditions accordion.
3. Create a Container Image condition.
4. Delete it.

Actual results:
"No Containerimage Conditions are defined ." message is shown.

Expected results:
List of Container Image conditions must be shown.

Comment 2 Harpreet Kataria 2016-05-26 15:10:07 UTC
Looks like that correct x_active_node is node being set after a Container Image condition is deleted. 

Right cell title should be fixed to that should say "All Container Image Conditions"
Also message should say "No Container Image Conditions are defined" instead of "No ContainerImage Conditions are defined"

Comment 3 Federico Simoncelli 2016-05-26 15:15:02 UTC
Zahi can you take this one? (Mooli should be able to give you more information if needed).

Comment 4 Mooli Tayer 2016-05-31 16:28:17 UTC
Zahi's patch was merged upstream:
https://github.com/ManageIQ/manageiq/pull/9021

Moving to post

Comment 5 Dmitry Misharov 2016-06-02 08:00:45 UTC
Verified fixed in 5.6.0.9-rc2.20160531154046_b4e2f6d.

Comment 7 errata-xmlrpc 2016-06-29 16:06:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.