Bug 134033 - X server ignores button press events
X server ignores button press events
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 00:06 EDT by Eric Taylor
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 03:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Taylor 2004-09-29 00:06:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:

After running a java-based I/O generator for a while, the system
gets into a state where the mouse can be moved and it is possible
to type into whichever window currently has the input focus, but
no button presses seems to get through.  If I rlogin and run xev,
I can move the cursor over xev and type.  I get event MotionNotify
events and KeyPress events, but no ButtonPress events.

I can flip to a virtual terminal (and out of the X server) and
use the mouse there.  I can move it and double-click to select
words, for example.

I flipped back to the X server and straced it, and it is getting
input on the file descriptor associated with the mouse when I press
a mouse button, but it looks like it never passes the button press
events along.

Killing the I/O generator frees things up.


Version-Release number of selected component (if applicable):
XFree86-4.3.0-35.EL

How reproducible:
Sometimes

Steps to Reproduce:
1.Run a I/O load generator to a half-dozen LUNs.
2.Wait several (maybe 12) hours.
3.Usually, the problem will show up.

    

Additional info:
Comment 1 Søren Sandmann Pedersen 2004-10-06 14:54:03 EDT
Is the IO generator available somewhere? 
Comment 2 Mike A. Harris 2005-03-07 12:28:37 EST
We require additional details and information in able to assess
this problem.  Without further response, there is nothing we
can do to investigate this issue.

Please update the bug status.  Thanks in advance.
Comment 4 Mike A. Harris 2005-05-12 03:13:32 EDT
This bug lacks detailed information that is sufficient enough to diagnose
the problem, and does not provide enough information to attempt to reproduce
the problem or be able to debug the issue.

If this is still a problem after applying all of the latest updates for this
release of the operating system, contact Red Hat Global Support Services
by logging into the Red Hat support website at http://www.redhat.com/support
or by contacting support via telephone at 1-888-RED-HAT1 and a support
associate will assist you.

Thanks in advance.

Setting status to "WONTFIX", as there's nothing we can do about this issue
as it stands currently.

Note You need to log in before you can comment on or make changes to this bug.