Bug 1340333 - Not able to join windows 10 clients to Samba PDC (NT4 style)
Summary: Not able to join windows 10 clients to Samba PDC (NT4 style)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba
Version: 6.3
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 05:06 UTC by Rama
Modified: 2019-11-14 08:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-31 07:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rama 2016-05-27 05:06:55 UTC
Description of problem:

We have SAMBA PDC Domain with domain name "example.com". Clients from windows XP and windows 7 are able to login without problem. If we are trying to join windows 10 PC. It produces error "Domain Could not be found. Check the domain name and try". If I have changed the domain name to "example" in smb.conf file( I removed "." from workgroup name, If I add again "." in workgroup name I was not able to join windows 8 and 10 clients) then I am able to join windows xp, 7, 8 and 10 without problem. What could be the problem. Our entire setup is using "example.com" domain name. If I change this to "example". It will be very panic job to us to migrate entire environment. Is there any way to join windows 10 PC into domain by keeping "example.com" domain name. We have tried with RHEL 6.7 with samba 3.6 also but the problem is same. Please help us in this regard. I have raised the support case to REDHAT Support Team for further analysis. Support Case Number is "01634476". We have posted this problem into SAMBA group also.

Version-Release number of selected component (if applicable):



How reproducible:

SAMBA PDC is able to support windows 10 if we change the domain name without ".com" i.e changing from "example.com" to "example".

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Andreas Schneider 2016-05-31 07:48:10 UTC
a) After Windows 7 Microsoft doesn't support joining a NT4 DC by default anymore. 
   It is only possible with several hacks [1].
b) A workgroup (netbios name) is normally not using any dots, it is possible but
   not recommended. As you're using a dot, Windows thinks it is a DNS name for an
   AD domain and not an NT4-style workgroup.
c) Also Samba 3.6 is very old (released 2011) and Windows 10 has been released 
   end of last year. Samba 3.6 doesn't support a lot of things Windows 10 
requires.

I'm sorry but don't expect support for Windows 10 with Samba 3.6.

[1] https://wiki.samba.org/index.php/Required_settings_for_NT4-style_domains

Comment 3 Andreas Schneider 2016-06-06 08:04:06 UTC
Just to be clear, we support running Samba as a PDC. But if Mircosoft decides to drop support for joining workstations to a NT4-style domain controller, it isn't Samba who is at fault.

Also note that Samba 3.6 is several years old. You should use a newer Samba version (4.2 or newer) and try your luck with that version. It might be that it works with newer protocol versions supported by newer Samba versions.


Note You need to log in before you can comment on or make changes to this bug.