Bug 1340356 - remove "Restore Saved Machine..." option from File menu of Connection Details window
Summary: remove "Restore Saved Machine..." option from File menu of Connection Details...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 07:08 UTC by zhoujunqin
Modified: 2016-11-04 02:02 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.4.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:02:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description zhoujunqin 2016-05-27 07:08:57 UTC
Description of problem:
"Restore Saved Machine...(Restore a saved machine from a filesystem image)" button doesn't work

Version-Release number of selected component (if applicable):
virt-manager-1.3.2-1.el7.noarch
qemu-kvm-rhev-2.6.0-4.el7.x86_64
libvirt-1.3.4-1.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Launch virt-manager.
# virt-manager

2. Make sure there is a guest in saved status, then try to restore it.
Click on one connection(QEMU/KVM)-->Edit-->Connection Details-->File-->click "Restore Saved Machine..." button.


Actual results:
After step2, no "Restore Saved Machine" windows pops up

Expected results:
After step2, "Restore Saved Machine" windows pops up and we can select saved file with no error


Additional info:

Comment 2 Pavel Hrdina 2016-05-31 11:20:14 UTC
This feature was removed by commit:

commit 839ce682b1e9dc792dd4ebe9bb611f0af1109adc
Author: Cole Robinson <crobinso>
Date:   Sat Apr 11 13:52:48 2015 -0400

    Drop support for non-managed save/restore
    
    All major drivers either support it, or don't support save at all,
    so I think we can safely drop it. If people still need it they can
    get by with virsh.

But that commit forget to remove also this menu option, so this feature doesn't work anymore and is replaced by "Shutdown -> Save" which is handled by managedsave feature provided by libvirt.

Comment 3 Pavel Hrdina 2016-06-01 08:01:17 UTC
Upstream commit:

commit 2d554aca7b2b5be0add78a8eadf3f66463608d71
Author: Pavel Hrdina <phrdina>
Date:   Tue May 31 13:09:48 2016 +0200

    ui: remove "Restore Saved Machine..." from File menu of Connection Details

Comment 5 XiaoyunHu 2016-06-23 03:16:14 UTC
I can reproduce this bug with package:
virt-manager-1.3.2-1.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch

Steps:
1. Launch virt-manager.
#virt-manager

2. Make sure there is a guest in saved status.

3. Click on one connection(QEMU/KVM) -->Edit --> Connection Details -->File, check if there is "Restore Saved Machine..." button.

4. Right click the restored machine, and click "Restore" button.

Results
After step3, the "Restore Saved Machine..." button does not appear.
After step4, the guest can be restored successfully.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 7 errata-xmlrpc 2016-11-04 02:02:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.