Bug 134036 - Incorrect locales set for Hindi and Tamil by system-config-language
Incorrect locales set for Hindi and Tamil by system-config-language
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: i18n
Depends On:
Blocks: FC3Target Indic
  Show dependency treegraph
 
Reported: 2004-09-29 01:37 EDT by Jatin Nansi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 07:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jatin Nansi 2004-09-29 01:37:03 EDT
Description of problem:
system-config-language sets locale to hi_IN for hindi and ta_IN for
tamil. Correct locale is hi_IN.UTF-8 for hindi and ta_IN.UTF-8 for tamil.

Version-Release number of selected component (if applicable):
system-config-language-1.1.6-2

How reproducible:
Every time

Steps to Reproduce:
1. Start system-config-language as root
2. Select Hindi/Tamil as the locale
3. Open terminal, run echo $LANG
  
Actual results:
locale set to hi_IN for hindi and ta_IN for tamil

Expected results:
hindi locale should be hi_IN.UTF-8
tamil locale should be ta_IN.UTF-8

Additional info:
tested on rawhide-20040923
Comment 1 Paul Nasrat 2004-09-29 05:22:29 EDT
We don't seem to have the utf8 locales in glibc-common so the non
UTF-8 ones are being used:

glibc-common-2.3.3-59

Do you have ta_IN.UTF-8 on your system? If so what package provides it
(rpm -qf /path/to/ta_IN.UTF-8)
Comment 2 Paul Nasrat 2004-09-29 06:18:31 EDT
Also what is contained within /etc/sysconfig/i18n
Comment 3 Jatin Nansi 2004-10-01 08:17:09 EDT
glibc does not yet have localedefs with .UTF8 (this is a bug. Will be
submitting a patch for this soon.)

However internally in gnome, for eg. hi_IN.UTF-8 locale is aliased to
hi_IN locale. Since it does pick up the locale definition from there.
This is correct for bn, gu, hi, pa and ta.

We also set the locale (LANG shell var) to the .UTF8 value in
/etc/sysconfig/i18n from anaconda, if selected as the default locale
during installation. As also in gdm when the user selects the Language
before logging in.

My /etc/sysconfig/i18n contains just this:
------------------------------------------------
LANG="bn_IN.UTF-8"
SYSFONT="latarcyrheb-sun16"
------------------------------------------------

The LANG variable is setup by anaconda run after selecting bengali as
the installation language.
Comment 4 Paul Nasrat 2004-10-01 08:29:23 EDT
OK it's the locale-list file - can you confirm if the following is
correct for Indic languages before I rebuild:

ar_IN.UTF-8 utf8 latarcyrheb-sun16 Arabic (India)
bn_IN.UTF-8 utf8 latarcyrheb-sun16 Bengali (India)
en_IN.UTF-8 utf8 latarcyrheb-sun16 English (India)
gu_IN.UTF-8 utf8 latarcyrheb-sun16 Gujarati (India)
hi_IN.UTF-8 utf8 latarcyrheb-sun16 Hindi (India)
mr_IN.UTF-8 utf8 latarcyrheb-sun16 Marathi (India)
pa_IN.UTF-8 utf8 latarcyrheb-sun16 Punjabi (India)
ta_IN.UTF-8 utf8 latarcyrheb-sun16 Tamil (India)
te_IN.UTF-8 utf8 latarcyrheb-sun16 Telgu (India)
Comment 5 Jatin Nansi 2004-10-04 03:31:32 EDT
Yes, confirming that the above is correct.
Comment 6 Paul Nasrat 2004-10-04 07:30:31 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.