Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1340380 - [RFE] Assume 'Active Directory Forest name' is by default equal to profile name
Summary: [RFE] Assume 'Active Directory Forest name' is by default equal to profile name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-extension-aaa-ldap
Classification: oVirt
Component: Setup
Version: 1.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.0.1
: 1.2.1
Assignee: Ondra Machacek
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 08:48 UTC by Jiri Belka
Modified: 2016-07-19 06:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:26:18 UTC
oVirt Team: Infra
mperina: ovirt-4.0.z?
grafuls: testing_plan_complete-
rule-engine: planning_ack?
mperina: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58453 0 None None None 2016-06-16 07:39:22 UTC

Description Jiri Belka 2016-05-27 08:48:21 UTC
Description of problem:

IMO it is annoying to type profile name - I suppose admins would usually write there domain name - and then to type _again_ 'Active Directory Forest name' (anyway, I did not know what 'Active Directory Forest name' is so I asked on of our developer; I think not everybody needs to know what this term means anyway, as the goal is to just add domain in (my) case).

So this RFE is about:

~~~
          Please specify profile name that will be visible to users: ad-w2k8r2.example.com
          Available LDAP implementations:
           1 - 389ds
           2 - 389ds RFC-2307 Schema
           3 - Active Directory
           4 - IPA
           5 - Novell eDirectory RFC-2307 Schema
           6 - OpenLDAP RFC-2307 Schema
           7 - OpenLDAP Standard Schema
           8 - Oracle Unified Directory RFC-2307 Schema
           9 - RFC-2307 Schema (Generic)
          10 - RHDS
          11 - RHDS RFC-2307 Schema
          12 - iPlanet
          Please select: 3
          Please enter Active Directory Forest name [ad-w2k8r2.example.com]:
                                                     ^^^ put assumed default
          ...and let the admin doing setup just hit 'Enter'
~~~

Less typing, more happy people, less confusion about terms they probably do not know.

(Maybe this would be good change as well...

~~~
          Please specify profile name (usually domain name): foobar
                                      ^^^^^^^^^^^^^^^^^^^^^^
~~~

as... what does it mean 'visible to users'?)


Version-Release number of selected component (if applicable):
ovirt-engine-extension-aaa-ldap-setup-1.2.0-0.2.el7ev.noarch

How reproducible:


Steps to Reproduce:
1. ovirt-engine-extension-aaa-ldap-setup
2. fill profile name
3. uh, what is 'Active Directory Forest name' and why do I have to type (probably domain name) again?

Actual results:
too much typing

Expected results:
less typing, just hitting enter when not explicitly mandatory

Additional info:

Comment 1 Martin Perina 2016-06-16 12:23:50 UTC
Patch is merged and will be part of ovirt-engine-extension-aaa-ldap-1.2.1, currently waiting for oVirt 4.0 GA release. After that, I will move to MODIFIED

Comment 2 Martin Perina 2016-06-23 13:40:59 UTC
Fix will be included in ovirt-engine-extension-aaa-ldap-1.2.1

Comment 3 Jiri Belka 2016-07-01 12:47:58 UTC
ok, ovirt-engine-extension-aaa-ldap-1.2.1-1.el7ev.noarch (brew)

...
          Please select: 3
          Please enter Active Directory Forest name: ad-w2k12r2.example.com
[ INFO  ] Resolving Global Catalog SRV record for ad-w2k12r2.example.com
[ INFO  ] Resolving LDAP SRV record for ad-w2k12r2.example.com
          NOTE:
          It is highly recommended to use secure protocol to access the LDAP server.
          Protocol startTLS is the standard recommended method to do so.
          Only in cases in which the startTLS is not supported, fallback to non standard ldaps protocol.
          Use plain for test environments only.
          Please select protocol to use (startTLS, ldaps, plain) [startTLS]: 
          Please select method to obtain PEM encoded CA certificate (File, URL, Inline, System, Insecure): 
[ ERROR ] Invalid value
          Please select method to obtain PEM encoded CA certificate (File, URL, Inline, System, Insecure): Insecure
[ INFO  ] Resolving SRV record 'ad-w2k12r2.example.com'
[ INFO  ] Connecting to LDAP using 'ldap://win-8a22spiopoi.ad-w2k12r2.example.com:389'
[ INFO  ] Executing startTLS
[ INFO  ] Connection succeeded
          Enter search user DN (empty for anonymous): 
[ INFO  ] Attempting to bind using '[Anonymous]'
          Are you going to use Single Sing-On for Virtual Machines (Yes, No) [No]: 
          Please specify profile name that will be visible to users [ad-w2k12r2.example.com]: 
[ INFO  ] Stage: Setup validation
          NOTE:
          It is highly recommended to test drive the configuration before applying it into engine.
          Perform at least one Login sequence and one Search sequence.
          Select test sequence to execute (Done, Abort, Login, Search) [Abort]: Done
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Transaction commit
[ INFO  ] Stage: Closing up
          CONFIGURATION SUMMARY
          Profile name is: ad-w2k12r2.example.com
          The following files were created:
              /etc/ovirt-engine/aaa/ad-w2k12r2.example.com.properties
              /etc/ovirt-engine/extensions.d/ad-w2k12r2.example.com-authz.properties
              /etc/ovirt-engine/extensions.d/ad-w2k12r2.example.com-authn.properties
[ INFO  ] Stage: Clean up
          Log file is available at /tmp/ovirt-engine-extension-aaa-ldap-setup-20160701102124-slxvh6.log:
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

Comment 4 Sandro Bonazzola 2016-07-19 06:26:18 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.