Bug 134041 - Unnecessary and continual device probing overloads CPU and degrades application responsiveness.
Unnecessary and continual device probing overloads CPU and degrades applicati...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 02:50 EDT by Ross Johnson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 01:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from ps showing hotplug processes (7.49 KB, text/plain)
2004-09-29 10:56 EDT, Ross Johnson
no flags Details

  None (edit)
Description Ross Johnson 2004-09-29 02:50:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
The system is constantly probing for a non-existent floppy drive. It
also continually connects and disconnects my (connected) USB printer.

The resulting CPU load severely degrades all application
responsiveness, delaying mouse and keyboard events, and making them
almost unusable. The log messages every 10 seconds or so are filling
up the message log.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2.
2. With or without updates (current at this date) applied.
3.

I.E. Nothing special has been done to the system.

Additional info:

Here's a section from /var/log/messages:

Sep 29 15:25:09 localhost kernel: updfstab: Using deprecated /dev/sg
mechanism instead of SG_IO on the actual device
Sep 29 15:25:09 localhost kernel: updfstab: Using deprecated /dev/sg
mechanism instead of SG_IO on the actual device
Sep 29 15:25:09 localhost kernel: inserting floppy driver for 2.6.8-1.521
Sep 29 15:25:09 localhost kernel: floppy0: Unable to grab IRQ6 for the
floppy driver
Sep 29 15:25:09 localhost modprobe: FATAL: Error inserting floppy
(/lib/modules/2.6.8-1.521/kernel/drivers/block/floppy.ko): Device or
resource busy
Sep 29 15:25:09 localhost kernel: usb 1-3: new high speed USB device
using address 47
Sep 29 15:25:10 localhost kernel: drivers/usb/class/usblp.c: usblp0:
USB Bidirectional printer dev 47 if 0 alt 0 proto 2 vid 0x04A9 pid 0x1088
Sep 29 15:25:16 localhost modprobe: FATAL: Error inserting floppy
(/lib/modules/2.6.8-1.521/kernel/drivers/block/floppy.ko): Device or
resource busy
Sep 29 15:25:16 localhost kernel: usb 1-3: USB disconnect, address 47
Sep 29 15:25:16 localhost kernel: drivers/usb/class/usblp.c: usblp0:
removed
Sep 29 15:25:16 localhost kernel: updfstab: Using deprecated /dev/sg
mechanism instead of SG_IO on the actual device
Sep 29 15:25:16 localhost kernel: updfstab: Using deprecated /dev/sg
mechanism instead of SG_IO on the actual device
Sep 29 15:25:16 localhost kernel: inserting floppy driver for 2.6.8-1.521
Sep 29 15:25:16 localhost kernel: floppy0: Unable to grab IRQ6 for the
floppy driver
Sep 29 15:25:17 localhost kernel: usb 1-3: new high speed USB device
using address 48
Sep 29 15:25:18 localhost kernel: drivers/usb/class/usblp.c: usblp0:
USB Bidirectional printer dev 48 if 0 alt 0 proto 2 vid 0x04A9 pid 0x1088
Sep 29 15:25:23 localhost kernel: usb 1-3: USB disconnect, address 48
Sep 29 15:25:23 localhost kernel: drivers/usb/class/usblp.c: usblp0:
removed


The IRQ6 referred to above is actually associated with my onboard
network device. From /proc/interrupts:

  6:     232858          XT-PIC  uhci_hcd, eth0

Running the gnome-system-monitor shows khelper spawning 2 or 3 high
priority (-10 niceness) 'sh' processes at the same time that
responsiveness degrades (at from 5 to 15 second intervals). I assume
these are hotplug shell scripts starting up.

I've marked the 'severity' as 'High' because user interaction is
severely disrupted and some applications that otherwise work fine are
unusable.
Comment 1 Ross Johnson 2004-09-29 10:56:24 EDT
Created attachment 104508 [details]
Output from ps showing hotplug processes

The system is an Intel Pentium 5 2.4GHz and it does appear to be the hotplug
scripts shown running at niceness -10 that are degrading responsiveness. I
haven't worked out why multiple usb.agent scripts need to run concurrently.
Comment 2 Bill Nottingham 2004-09-29 16:14:13 EDT
'install floppy /bin/true' in /etc/modprobe.conf will fix the floppy
errors.

As to why you're getting constant connect/disconnects from the USB
printer, that sounds more like a kernel issue.
Comment 3 Ross Johnson 2004-09-30 01:49:39 EDT
Problem fixed!

Thanks for the clue re kernel problem - I'm not familiar with how this
all plays together.

I rechecked the BIOS settings and set 'Plug & Play OS' = 'Yes', which
appears to fix both problems (floppy module load attempt and USB
printer connect/disconnect).

The motherboard is an ASUS P4G8X series, and factory default P&P OS
setting is 'No'. I also wasn't sure if Linux was Plug&Play compatible,
so left the default setting alone when I originally set it up. The
machine is dual-boot with Windows 2000, which appears to work fine
with BIOS P&P=No. Red Hat 9 didn't appear to have problems initially
either, although it did start losing the USB printer after an update
at one stage if I recall correctly.

Note You need to log in before you can comment on or make changes to this bug.