Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1340422 - Breadcrumb navigation error in about page when navigated from service catalogs item page
Summary: Breadcrumb navigation error in about page when navigated from service catalog...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Zita Nemeckova
QA Contact: Shveta
URL:
Whiteboard: ui:catalog
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 11:24 UTC by Aziza Karol
Modified: 2016-07-26 08:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-26 08:46:16 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
breadcrumb (78.88 KB, image/png)
2016-05-27 11:24 UTC, Aziza Karol
no flags Details

Description Aziza Karol 2016-05-27 11:24:55 UTC
Created attachment 1162422 [details]
breadcrumb

Description of problem:


Version-Release number of selected component (if applicable):
5.6.0.8-rc1


How reproducible:
100%

Steps to Reproduce:
1.Navigate to services->catalogs
2.click on any catalog item in "All Catalog Items"
3.then navigate to settings->about page

Actual results:
Breadcrumb displayed.see attached screenshot.clicking on the breadcrumb link displays "The page you were looking for doesn't exist"

Expected results:
No breadcrumb should be displayed.

Additional info:

Comment 2 Harpreet Kataria 2016-05-27 14:41:04 UTC
Zita,

It looks like breadcrumbs links are being built incorrectly for catalog explorer. I think you need to add service_template to the list here https://github.com/ManageIQ/manageiq/blob/master/app/controllers/application_controller/ci_processing.rb#L1061 let me know if you need help with recreating this or need further help with this.

Thanks,
~Harpreet

Comment 3 Zita Nemeckova 2016-07-26 08:46:16 UTC
Hi,

I can't reproduce it on master nor on 5.5.4 nor 5.6.0.2. It looks like there is no longer a breadcrumb.


Note You need to log in before you can comment on or make changes to this bug.