Bug 134044 - don't show multibyte i18n message
Summary: don't show multibyte i18n message
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: indent   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-29 07:28 UTC by Wei-Lun Chao
Modified: 2015-05-05 01:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 13:32:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
newer po file with utf-8 coded messages (7.06 KB, text/plain)
2006-02-03 13:49 UTC, Wei-Lun Chao
no flags Details

Description Wei-Lun Chao 2004-09-29 07:28:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.7.3)
Gecko/20040922

Description of problem:
some i18n message with multibyte (or utf-8) locale,
such as ru, zh
will be dispalyed only as question marks
in terminal window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
LANG=ru_RU indent --xx


Actual Results:  indent: ??????????? ????? "-xx"

Additional info:

Comment 1 Petr Machata 2006-02-01 13:32:52 UTC
There is a fix in rawhide. Since this is an old bug, and I don't know if you are
still interested, I'm closing it; but feel free to reopen if it doesn't do what
you want.

Comment 2 Wei-Lun Chao 2006-02-03 13:49:41 UTC
Created attachment 124104 [details]
newer po file with utf-8 coded messages

the fix works, but one of the mo file:
/usr/share/locale/zh_TW.Big5/LC_MESSAGES/indent.mo
should be replaced through the attached po file and moved to:
/usr/share/locale/zh_TW/LC_MESSAGES/indent.mo

Thanks!

Comment 3 Petr Machata 2006-02-03 16:05:07 UTC
Thank you, the change will appear in rawhide shortly.


Note You need to log in before you can comment on or make changes to this bug.