Bug 1340475 - Nova novnc console doesn't load 2/3 times: Failed to connect to server (code: 1006)
Summary: Nova novnc console doesn't load 2/3 times: Failed to connect to server (code:...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Sven Anderson
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On: 1361301
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 13:42 UTC by Marius Cornea
Modified: 2016-08-11 11:31 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-27.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1361301 (view as bug list)
Environment:
Last Closed: 2016-08-11 11:31:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 348248 None None None 2016-07-28 11:23:18 UTC
OpenStack gerrit 348255 None None None 2016-07-28 11:23:36 UTC

Description Marius Cornea 2016-05-27 13:42:59 UTC
Description of problem:
Nova novnc console fails to load 2/3 requests in an HA environment with 3 controllers. The issue seems pretty much the same as the one reported in BZ#1238336

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-2.0.0-8.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud 
2. Log in to Horizon
3. Access instance console

Actual results:
2/3 times you get the following message:
Failed to connect to server (code: 1006)

Expected results:
The noVNC console always gets loaded.

Additional info:
The memcached servers are set in nova.conf:
[root@overcloud-controller-0 heat-admin]# grep memcached_servers /etc/nova/nova.conf 
# "memcached_servers" opt is deprecated in Mitaka. In Newton release oslo.cache
#memcached_servers=<None>
#memcached_servers=<None>
memcached_servers=10.0.0.15:11211,10.0.0.14:11211,10.0.0.13:11211

Comment 2 Marius Cornea 2016-06-09 20:29:15 UTC
In Mitaka the memcached_servers option got deprecated:
http://docs.openstack.org/releasenotes/nova/mitaka.html

I tried the following workaround on master and it fixed the issue for me:

On controller nodes in /etc/nova/nova.conf add this cache section:

[cache]
backend = oslo_cache.memcache_pool
enabled = true
memcache_servers = 10.0.0.15:11211,10.0.0.14:11211,10.0.0.13:11211

Comment 8 errata-xmlrpc 2016-08-11 11:31:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.