Bug 1340476 - [rbd-mirror] multiple replicated pools results in incorrect replication status
Summary: [rbd-mirror] multiple replicated pools results in incorrect replication status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 13:45 UTC by Jason Dillaman
Modified: 2017-07-30 15:28 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-10.2.1-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:39:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 16045 0 None None None 2016-05-27 13:44:59 UTC
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Jason Dillaman 2016-05-27 13:45:00 UTC
Description of problem:
When a cluster has two or more replicated pools, the rbd-mirror daemon will attempt to replicate a single image multiple times (once for each pool).  This results in the status ping-ponging back-and-forth between replaying and bootstrapping.  It also results in numerous error messages in the logs.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create two or more replicated pools
2. put at least one replicated image in a pool

Actual results:
Use 'rbd mirror pool status' to see the health warning

Expected results:
No health warning.

Additional info:

Comment 6 Hemanth Kumar 2016-06-16 18:27:40 UTC
Not seeing any errors while replicating 2 0r more pools 
Verified by checking the pool status,
# rbd mirror pool status pool3 --cluster master
health: OK
images: 196 total
    196 stopped

Moving to verified state.

Comment 8 errata-xmlrpc 2016-08-23 19:39:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.