Bug 134048 - CPAN Shell is not intergrated with up2date
Summary: CPAN Shell is not intergrated with up2date
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-29 08:17 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 23:46:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2004-09-29 08:17:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
The Perl way of installing Perl modules - the CPAN shell - is not
intregrated with up2date.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Damian Menscher 2005-01-04 03:16:29 UTC
I can't imagine how to resolve this issue, but it's certainly becoming
an important one.  We're running RHEL 3, which is old enough that many
perl modules are horribly out-of-date.  Unfortunately there doesn't
seem to be any clean way to update them, since using CPAN breaks the
RPM package management.  Are we expected to simply compile our own RPMs?

I don't think there is an easy answer to this, but hopefully some
developer will see this and think of a good solution.

Comment 2 Need Real Name 2005-01-04 08:05:44 UTC
http://perl.arix.com/cpan2rpm/ is one solution, and CPANplus will have
an interface to up2date.

Neither address the problem of very outdated perl modules hanging
around in RHEL3, with its long shelf life.

Comment 3 Rob Kearey 2005-02-16 07:04:29 UTC
Also check out Ovid:

http://search.cpan.org/dist/Ovid/



Comment 4 Warren Togami 2005-05-17 23:45:42 UTC
https://www.redhat.com/mailman/listinfo/fedora-perl-devel-list
CPAN is the wrong way to install stuff on RPM based distributions.  Please join
the fedora-perl-devel-list team to help in putting more perl CPAN modules into
Extras, which is the only non-fragile way of doing this.


Note You need to log in before you can comment on or make changes to this bug.