Bug 1340482 - [rbd-mirror] image deletions are not propagated to peer cluster
Summary: [rbd-mirror] image deletions are not propagated to peer cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Hemanth Kumar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 14:03 UTC by Jason Dillaman
Modified: 2017-07-30 15:33 UTC (History)
4 users (show)

Fixed In Version: RHEL: ceph-10.2.1-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:39:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 14421 0 None None None 2016-05-27 14:03:39 UTC
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Jason Dillaman 2016-05-27 14:03:40 UTC
Description of problem:
When a primary image is deleted, this deletion operation should be propagated to the non-primary cluster.  Additionally, if replication is disabled for the primary image, the non-primary image should be deleted.

Version-Release number of selected component (if applicable):
10.2.1

How reproducible:
100%

Steps to Reproduce:
1. Delete a primary image or disabling mirroring on the primary image

Actual results:
The image remains in the non-primary cluster.  If a new image with the same name is recreated or if replication is re-enabled, you will receive a split-brain error.

Expected results:
The non-primary image will be deleted.

Additional info:

Comment 4 Hemanth Kumar 2016-06-27 12:45:50 UTC
Deletion of image and disabling the image is propagated to the remote rbd host.
Verified in v10.2.2-5 build.
Moving to verified state

Comment 6 errata-xmlrpc 2016-08-23 19:39:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.