Bug 1340484 - [rbd-mirror] cloned images are not replicated
Summary: [rbd-mirror] cloned images are not replicated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Hemanth Kumar
URL:
Whiteboard:
: 1340124 (view as bug list)
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-05-27 14:07 UTC by Jason Dillaman
Modified: 2017-07-30 15:30 UTC (History)
3 users (show)

Fixed In Version: RHEL: ceph-10.2.1-18.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 14937 0 None None None 2016-05-27 14:07:02 UTC
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Jason Dillaman 2016-05-27 14:07:02 UTC
Description of problem:
Cloned images with replication enabled are not replicated.

Version-Release number of selected component (if applicable):
10.2.1

How reproducible:
100%

Steps to Reproduce:
1. Clone an image
2. Enable replication

Actual results:
A blank image is created on the non-primary cluster but the contents are not replicated.

Expected results:
The cloned image should replicate to the non-primary cluster once its parent image has been replicated.

Additional info:

Comment 2 Jason Dillaman 2016-05-31 11:30:41 UTC
Upstream PR: https://github.com/ceph/ceph/pull/9375

Comment 4 Christina Meno 2016-06-08 18:04:37 UTC
*** Bug 1340124 has been marked as a duplicate of this bug. ***

Comment 6 Hemanth Kumar 2016-06-16 16:17:24 UTC
Cloned Images are getting replicated to the Secondary cluster.

Moving the Bz to verified state.

Comment 8 errata-xmlrpc 2016-08-23 19:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.