Bug 134057 - sudden swap storm forces me to reboot
sudden swap storm forces me to reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-29 06:46 EDT by Tim Waugh
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 09:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-09-29 06:46:23 EDT
Description of problem:
Three times this month (twice this week) I have had to reboot this
uniprocessor AMD Duron because the machine will quite suddenly (within
the space of a minute or two) go into a swap frenzy.  When this
happens, no progress is observed at all.  I can't switch virtual
consoles.  I can't log in remotely.

Alt-SysRq-E (to SIGTERM all tasks) eventually stops it, but at that
point nothing will display on the screen and sshd is also dead, so I
have to reboot anyway.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Don't know how to reproduce it, but it happens enough to be really
annoying.
Comment 1 Tim Waugh 2004-09-29 14:35:31 EDT
This just happened *again*.  This time I was burning a CD using
cdrecord and suddenly the machine became completely unresponsive.  The
disk was in constant use.

It has happened before while burning a CD.  Perhaps it's related to
that? (It's also happened when I'm not doing that.)
Comment 2 Arjan van de Ven 2004-09-29 14:39:29 EDT
hmm audio cd by chance ???
Comment 3 Tim Waugh 2004-09-30 04:26:17 EDT
Yes.
Comment 4 Tim Waugh 2004-09-30 12:30:51 EDT
This just happened again, but I was not burning a CD at all.  Two
local users logged in, Mozilla, Firefox, Evolution and GIMP were all
that was running.
Comment 5 Tim Waugh 2004-09-30 15:14:11 EDT
Happened again with even lighter load.  This time I was running
2.6.8-1.521 (latest FC2 kernel) to try to avoid the problem.

I'll try 2.6.8-1.590.
Comment 6 Tim Waugh 2004-10-04 07:34:01 EDT
FWIW, I haven't seen this again yet with 2.6.8-1.590.
Comment 7 Tim Waugh 2004-10-10 06:58:03 EDT
Still haven't seen this again.  I only switched from 1.590 (to 1.603)
today.  Looks like this might be fixed?
Comment 8 Tim Waugh 2004-10-14 09:18:31 EDT
Pretty sure this is fixed now.

Note You need to log in before you can comment on or make changes to this bug.