Bug 1340702 - Can't assign static ip for a network that is attached to the same interface as the management network
Summary: Can't assign static ip for a network that is attached to the same interface a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.0.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Alona Kaplan
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1255474 1348448
TreeView+ depends on / blocked
 
Reported: 2016-05-30 06:20 UTC by Michael Burman
Modified: 2016-07-05 07:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1348448 (view as bug list)
Environment:
Last Closed: 2016-07-05 07:58:54 UTC
oVirt Team: Network
rule-engine: ovirt-4.0.0+
ylavi: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine log (289.48 KB, application/x-gzip)
2016-05-30 06:20 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58538 0 master MERGED engine: Can't assign ip for a network attached to the same nic as mgmt 2016-06-06 09:43:28 UTC
oVirt gerrit 58658 0 ovirt-engine-4.0 MERGED engine: Can't assign ip for a network attached to the same nic as mgmt 2016-06-06 16:05:43 UTC
oVirt gerrit 59619 0 ovirt-engine-3.6 MERGED engine: Can't assign ip for a network attached to the same nic as mgmt 2016-06-27 09:11:00 UTC

Description Michael Burman 2016-05-30 06:20:22 UTC
Created attachment 1162674 [details]
engine log

Description of problem:
Can't assign static ip for a network that is attached to the same interface as the management network. 

When trying to assign a static ip for a network that is assignet to the same interface as the management network - 'ovirtmgmt', failing with the next error: 

Error while executing action: 

pink-vds2.qa.lab.tlv.redhat.com:
Cannot setup Networks. The address of the network 'iperf-net' cannot be modified without reinstalling the host, since this address was used to create the host's certification.

2016-05-30 09:09:51,686 WARN  [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (default task-1) [4a892aa4] Validation of action 'HostSetupNetworks' failed for user admin@internal-authz. Reasons: VAR__ACTION__SETUP,VAR__TYPE__NETWORKS,ACTION_TYPE_FAILED_NETWORK_ADDRESS_CANNOT_BE_CHANGED,$ACTION_TYPE_FAILED_NETWORK_ADDRESS_CANNOT_BE_CHANGED_LIST iperf-net
2016-05-30 09:09:51,686 INFO  [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (default task-1) [4a892aa4] Lock freed to object 'EngineLock:{exclusiveLocks='[2f2023f3-91b7-4c47-886e-669e87d30bb8=<HOST_NETWORK, ACTION_TYPE_FAILED_SETUP_NETWORKS_IN_PROGRESS>]', sharedLocks='null'}'


Version-Release number of selected component (if applicable):
4.1.0-0.0.master.20160529171307.git359707b.el7.centos.noarch


How reproducible:
100

Steps to Reproduce:
1. Add host to ovirt engine 4.0
2. Attach vlan network to the same interface to which the management network attached to via the setrup networks 
3. Set static ip over the vlan network and try to approve operation

Actual results:
Failed with error - 
Cannot setup Networks. The address of the network 'iperf-net' cannot be modified without reinstalling the host, since this address was used to create the host's certification.

Expected results:
Should work as expected as we not trying to change the address of the management network. 

Additional info:
Discovered during the testing of BZ -1255474

Comment 1 Yaniv Kaul 2016-05-30 14:34:02 UTC
In any case, the text '...the host's certification' is quite wrong, English-wise (should be 'certificate'). Should be a separate bug.

Comment 5 Alona Kaplan 2016-06-14 06:14:06 UTC
Yes, the bug exists in 3.6 as well, but only if you add your host via an IP address, instead of the recommended FQDN (4.0 had the bug for both).

To solve the bug for 3.6.z, please clone it to RHEVM, request the 3.6.z flag and state the business case (as customers should be advised to use FQDN anyway).

Comment 6 Michael Burman 2016-06-14 06:37:33 UTC
Verified on - 4.0.0.4-0.1.el7ev

Comment 7 Sandro Bonazzola 2016-07-05 07:58:54 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.