Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1340716 - Attached cloud volume is still available for attaching
Summary: Attached cloud volume is still available for attaching
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Tzu-Mainn Chen
QA Contact: Ola Pavlenko
URL:
Whiteboard: volume
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-30 07:12 UTC by Tsai Li Ming
Modified: 2018-01-05 23:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:03:18 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)

Description Tsai Li Ming 2016-05-30 07:12:25 UTC
Description of problem:

After a cloud volume has been attached, the volumes dropdown box is still populated with the same volume names. After clicking on submit, there is no indication that the operation has failed.

evm.log has the following error:
[----] E, [2016-05-30T15:07:55.751729 #13899:ecb38c] ERROR -- : <Fog> excon.error     #<Excon::Errors::BadRequest: Expected([200, 
202]) <=> Actual(400 Bad Request)
excon.error.response
  :body          => "{\"badRequest\": {\"message\": \"Invalid volume: volume 'ca29ed6b-3650-4e80-a61d-e711cc9578fb' status must be
 'available'. Currently in 'in-use'\", \"code\": 400}}"



Version-Release number of selected component (if applicable):
- CF 4.1 Beta3
- 5.6.0.8-rc1.20160524155303_f2a5a50

How reproducible:
Always

Steps to Reproduce:
1. Attach a volume and confirm the volume has been attached successfully. 
2. Attempt to attach another volume. Observe the volume in step #1 is still available.
3. Submit the request and nothing happens.

Actual results:
User can choose unavailable cloud volume to attach

Expected results:
User should not be able to choose unavailable volumes. 

Additional info:

Comment 2 Tsai Li Ming 2016-05-30 07:18:26 UTC
Detaching volume list does show correctly but only after "Refresh Relationships and Power States" has been done.

Comment 3 Chris Pelland 2017-08-21 13:03:18 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.