Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1340747 - there are no or wrong units in graphs (across the entire RHSC 2.0 web ui)
Summary: there are no or wrong units in graphs (across the entire RHSC 2.0 web ui)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2
Assignee: kamlesh
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-30 08:47 UTC by Martin Kudlej
Modified: 2016-08-23 19:52 UTC (History)
4 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
"General" graph (16.70 KB, image/png)
2016-05-30 08:56 UTC, Martin Kudlej
no flags Details
CPU, Memory timebased graph (25.74 KB, image/png)
2016-05-30 08:58 UTC, Martin Kudlej
no flags Details
graphs next to IOPS, Throughput, Latency (26.15 KB, image/png)
2016-05-30 09:06 UTC, Martin Kudlej
no flags Details
screenshot 3: pool list page with almost empty pools (68.56 KB, image/png)
2016-07-04 14:36 UTC, Martin Bukatovic
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-05-30 08:47:34 UTC
Description of problem:
There are graphs in UI which has no description or wrong description. There are no units in graphs. Also if graphs are time based user doesn't know what value was valid in which time. So there are graphs, but it is not obvious what they display.

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-15.el7scon.noarch
ceph-installer-1.0.11-1.el7scon.noarch
rhscon-ceph-0.0.19-1.el7scon.x86_64
rhscon-core-0.0.20-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. create cluster and pool
2. create some traffic in Ceph pool

Actual results:
There are no or wrong units in graphs.

Expected results:
There are right units in ALL graphs.

Comment 1 Martin Kudlej 2016-05-30 08:56:20 UTC
Created attachment 1162716 [details]
"General" graph

There is no units in graph "General". Also it seems that pointer should show non-zero value. It is time-based graph but time units(timestamps) are not displayed.

Comment 2 Martin Kudlej 2016-05-30 08:58:39 UTC
Created attachment 1162730 [details]
CPU, Memory timebased graph

There are 2 timebased graphs(CPU, Memory) without timestamps/units.

Comment 3 Martin Kudlej 2016-05-30 09:06:25 UTC
Created attachment 1162732 [details]
graphs next to IOPS, Throughput, Latency

There are timebased graphs next to IOPS, Throughtput, Latency. It is not obvious is those graphs belong to numbers on the left. They are timebased but there are no timestamps/units. There are also wrong units if those graphs belong to numbers on the left - for example: "8810 used" next to number with units "KB/s Throughput". Does it mean that 8810 KB/s are used? From which range are 8810 used?

Comment 4 Martin Bukatovic 2016-07-04 14:36:37 UTC
Created attachment 1176082 [details]
screenshot 3: pool list page with almost empty pools

Checking with rhscon-ui-0.0.42-1.el7scon.noarch

Wrong units are shown for pool capacity values in a pool list on "Pools" page
when a pool is almost empty (total space used is smalled than 1MB). As can bee
seen on the attached screenshot, the Pools list items states:

 * rbd_pool: 7.3 KB
 * abc_pool: 114.0 B
 * def_pool: 114.0 B

While the actual size is different:

~~~
#  ceph -c /etc/ceph/alpha.conf df detail 
GLOBAL:
    SIZE       AVAIL      RAW USED     %RAW USED     OBJECTS 
    40915M     40760M         155M          0.38          24 
POOLS:
    NAME         ID     CATEGORY     QUOTA OBJECTS     QUOTA BYTES     USED     %USED     MAX AVAIL     OBJECTS     DIRTY     READ      WRITE     RAW USED 
    rbd_pool     1      -            N/A               N/A             7486         0        13586M          16        16     43389        40        22458 
    abc_pool     2      -            N/A               N/A              114         0        13586M           4         4      9402         8          342 
    def_pool     3      -            1                 N/A              114         0        13586M           4         4      9339         8          342
~~~

Note that the default implicit value in 'ceph df' output are *kilobytes*, as
can be found in the ceph docs[1]:

> USED: The notional amount of data stored in kilobytes, unless the number
> appends M for megabytes or G for gigabytes.

[1] http://docs.ceph.com/docs/master/rados/operations/monitoring/

Comment 5 Martin Bukatovic 2016-07-04 14:37:43 UTC
Based on findings from comment 4, moving back to ASSIGNED.

Comment 6 Martin Bukatovic 2016-07-04 14:40:32 UTC
(In reply to Martin Bukatovic from comment #4)
> when a pool is almost empty (total space used is smalled than 1MB).

Actually as can be seen for rbd_pool (which uses 7.5 MB) from comment 4, the
pool can use more space than just 1 MB - the key detail is that the unit is
not shown by 'ceph df'.

Comment 8 Martin Kudlej 2016-07-21 11:42:48 UTC
This bug is still valid for 
ceph-ansible-1.0.5-31.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.34-1.el7scon.x86_64
rhscon-core-0.0.35-1.el7scon.x86_64
rhscon-core-selinux-0.0.35-1.el7scon.noarch
rhscon-ui-0.0.49-1.el7scon.noarch
There are still timestamps missing in graphs so user doesn't know when was reported which value. --> ASSIGNED

Comment 9 Nishanth Thomas 2016-07-21 14:11:06 UTC
As per the bug scrub, moving it back to verified state. Raise an RFE if you feel that time stamps are required for each and every graphs

Comment 12 errata-xmlrpc 2016-08-23 19:52:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.