Bug 1340767 - [RFE] Please consider to use PANGO_LANGUAGE for GNOME Desktop in fonts-tweak-tool
Summary: [RFE] Please consider to use PANGO_LANGUAGE for GNOME Desktop in fonts-tweak-...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fonts-tweak-tool
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-30 09:19 UTC by Peng Wu
Modified: 2016-06-01 04:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-01 04:53:10 UTC
Type: Bug


Attachments (Terms of Use)
Chinese locale, without ~/.i18n (56.53 KB, image/png)
2016-05-31 07:40 UTC, Peng Wu
no flags Details
English locale, with "export FC_LANG=zh_CN" in ~/.i18n (61.25 KB, image/png)
2016-05-31 07:41 UTC, Peng Wu
no flags Details
English locale, with "export PANGO_LANGUAGE=zh_CN" in ~/.i18n (59.71 KB, image/png)
2016-05-31 07:42 UTC, Peng Wu
no flags Details

Description Peng Wu 2016-05-30 09:19:11 UTC
Recently some Chinese user reports that they use English locale by default,
But still want to use Chinese when reading/writing.

For GNOME 3.x, when use FC_LANG=zh_CN in ~/.i18n, the English character
becomes slightly bolder.
With PANGO_LANGUAGE=zh_CN in ~/.i18n, the English character is the same.

Please evaluate it, thanks!

Comment 1 Akira TAGOH 2016-05-31 04:00:50 UTC
Screenshot or the steps to reproduce, please?

Comment 2 Peng Wu 2016-05-31 07:40:11 UTC
Created attachment 1163062 [details]
Chinese locale, without ~/.i18n

Comment 3 Peng Wu 2016-05-31 07:41:31 UTC
Created attachment 1163063 [details]
English locale, with "export FC_LANG=zh_CN" in ~/.i18n

Comment 4 Peng Wu 2016-05-31 07:42:26 UTC
Created attachment 1163064 [details]
English locale, with "export PANGO_LANGUAGE=zh_CN" in ~/.i18n

Comment 5 Peng Wu 2016-05-31 07:44:18 UTC
Sure, screenshots uploaded.

Comment 6 Akira TAGOH 2016-05-31 09:23:57 UTC
Thanks. hmm, does FC_LANG=en:zh_CN give you the same result?

Comment 7 Peng Wu 2016-05-31 10:28:48 UTC
Yes, it looks similar.

Comment 8 Akira TAGOH 2016-05-31 10:38:59 UTC
Then I'd suggest to add English prior to Chinese on fonts-tweak-tool. that should works unless applications uses rich rendering libraries like pango and Qt which supports the sort of the font sets.
this is because pango takes care of ascii characters separately and requests an English font unless you explicitly override that behavior in the font configuration.

Comment 9 Peng Wu 2016-06-01 04:47:29 UTC
Thanks, it is a good solution for Chinese locale by adding English first.

Comment 10 Akira TAGOH 2016-06-01 04:53:10 UTC
Okay, I'll close this then. thanks.


Note You need to log in before you can comment on or make changes to this bug.