Bug 134080 - cupsd not started after clicking "Apply"
Summary: cupsd not started after clicking "Apply"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-09-29 14:38 UTC by Nader Khalid Alzain
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.1.21-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 14:54:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nader Khalid Alzain 2004-09-29 14:38:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
cupsd process crashes after making any changes in
system-config-printer and clicking "Apply"

Version-Release number of selected component (if applicable):
system-config-printer-0.6.112-1 and cups-1.1.21-1.rc2.1

How reproducible:
Always

Steps to Reproduce:
1. make sure cupsd is already running
2. bring up system-config-printer
3. make any change to an existing printer
4. click "Apply"
    

Actual Results:  cupsd process disappears

Expected Results:  cupsd restarted fine

Additional info:

Nothing interesting in /var/log/cups/error_log.
"/etc/init.d/cups start" put things back in order

Comment 1 Tim Waugh 2004-09-29 16:38:33 UTC
Please try with cups-1.1.21-3.  Thanks.

Comment 2 Nader Khalid Alzain 2004-09-30 13:02:17 UTC
I installed cups-1.1.21-3, but without change in behavior.
I tried a different scenario:
1. Manually stop cupsd
2. Bring up system-config-printer and press "Apply"
The result is that cupsd now starts up fine!
I feel it is a simple issue with the code behind "Apply" button not
properly handling stopping/starting/restarting sequences. This bug
does not happen in system-config-printer-0.6.98-1.
I've downgraded priority to normal since I don't show any evidence of
cups crashing.

Comment 3 Tim Waugh 2004-09-30 13:06:17 UTC
What does /sbin/chkconfig --list cups say?

Are there jobs in the queue at the point you press "Apply"?

Comment 4 Nader Khalid Alzain 2004-09-30 13:19:46 UTC
[nelzein@envoy ~]$ /sbin/chkconfig --list cups
cups            0:off   1:off   2:on    3:on    4:on    5:on    6:off
No jobs running in any of the test cases.

Comment 5 Tim Waugh 2004-10-04 11:33:43 UTC
I see this here now.  cupsd is segfaulting shortly after getting the
SIGHUP.

Comment 6 Tim Waugh 2004-10-04 13:53:21 UTC
Please try cups-1.1.21-5.

Comment 7 Nader Khalid Alzain 2004-10-05 14:42:56 UTC
I have installed cups-1.1.21-5 and tested successfully.
system-config-printer works fine, and the bug can be closed.
Thank you!


Note You need to log in before you can comment on or make changes to this bug.