Bug 1340822 - OS_AUTH_URL for AODH points to localhost
Summary: OS_AUTH_URL for AODH points to localhost
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-30 11:05 UTC by Yurii Prokulevych
Modified: 2016-08-11 11:31 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-12.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:31:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Yurii Prokulevych 2016-05-30 11:05:06 UTC
Description of problem:
AODH installed with director. 'os_auth_url' from service_credentials section points to localhost:

# Auth URL to use for OpenStack service access. (string value)
# Deprecated group/name - [DEFAULT]/os_auth_url
#os_auth_url = http://localhost:5000/v2.0

os_auth_url = http://localhost:5000/v2.0


This causes some of gnocchi* alarms to fail.

Packages:
openstack-aodh-evaluator-2.0.0-1.el7ost.noarch
openstack-aodh-api-2.0.0-1.el7ost.noarch
openstack-aodh-notifier-2.0.0-1.el7ost.noarch
python-aodh-2.0.0-1.el7ost.noarch
openstack-aodh-common-2.0.0-1.el7ost.noarch
openstack-aodh-listener-2.0.0-1.el7ost.noarch

openstack-tripleo-image-elements-0.9.9-3.el7ost.noarch
python-tripleoclient-2.0.0-1.0.2.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-8.el7ost.noarch
openstack-tripleo-common-2.0.0-5.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-8.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-2.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch

Steps to Reproduce:
1. Deploy command:
 openstack overcloud deploy --templates --libvirt-type qemu --ntp-server clock.redhat.com --control-scale 3 --compute-scale 2 --ceph-storage-scale 2


Additional info:
Virtual setup - 3 controllers, 2computes, 2 ceph

Comment 6 Yurii Prokulevych 2016-07-19 13:16:25 UTC
grep -i os_auth_url /etc/aodh/aodh.conf 
os_auth_url=http://192.0.2.1:5000/v2.0

Alarms(threshold/composite(and|or)) are created and transition between states.

Packages:
---------
openstack-aodh-notifier-2.0.1-3.el7ost.noarch
python-aodh-2.0.1-3.el7ost.noarch
openstack-aodh-api-2.0.1-3.el7ost.noarch
openstack-aodh-evaluator-2.0.1-3.el7ost.noarch
python-aodh-tests-2.0.1-3.el7ost.noarch
openstack-aodh-listener-2.0.1-3.el7ost.noarch
openstack-aodh-common-2.0.1-3.el7ost.noarch

openstack-tripleo-heat-templates-2.0.0-15.el7ost.noarch

Comment 8 errata-xmlrpc 2016-08-11 11:31:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.