Bug 1340855 - Calamari returns empty dictionary for mon status api
Summary: Calamari returns empty dictionary for mon status api
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: rakesh
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-05-30 12:29 UTC by anmol babu
Modified: 2016-08-23 19:40 UTC (History)
6 users (show)

Fixed In Version: calamari-server-1.4.1-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:40:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description anmol babu 2016-05-30 12:29:31 UTC
Description of problem:
With calamari on only one of the mons in the cluster,the mon status api returns empty json for mons without calamari running. However, the status is obtained correctly for mon on which calamari is running.

Version-Release number of selected component (if applicable):
calamari-server-1.4.0-0.10.rc13.el7cp.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create cluster
2. Invoke the calamari api cluster/{cluster-fsid}/mon/{mon-name}/status?format=json with mon-name as the mon name of mon without calamari running

Actual results:
The api returns empty dictionary

Expected results:
The api should return appropriate response.

Additional info:
We are using calamari on one mon in rhscon. And we found the issue in calamari on one mon

Comment 2 Christina Meno 2016-06-09 04:14:59 UTC
https://github.com/ceph/calamari/pull/459

Comment 4 Christina Meno 2016-06-14 17:47:17 UTC
v1.4.1

Comment 6 Shubhendu Tripathi 2016-06-17 12:21:13 UTC
Find it working with build calamari-server-1.4.2-1.el7cp.x86_64

Comment 7 Harish NV Rao 2016-06-22 12:25:42 UTC
cluster/{cluster-fsid}/mon/{mon-name}/status?format=json is now displaying: 
{"election_epoch": null, "quorum": [0, 1, 2], "rank": 1}

Comment 9 errata-xmlrpc 2016-08-23 19:40:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.