Bug 1340888 - [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set
Summary: [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-...
Keywords:
Status: CLOSED DUPLICATE of bug 1316617
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3d39da3bb52ff728109278f9b5c...
: 1341842 1349464 1349801 1352209 1357396 1359719 1359880 1360494 1360543 1362703 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-30 14:51 UTC by Craig Robson
Modified: 2016-08-02 22:15 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-02 06:09:21 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (836 bytes, text/plain)
2016-05-30 14:51 UTC, Craig Robson
no flags Details
File: environ (88 bytes, text/plain)
2016-05-30 14:51 UTC, Craig Robson
no flags Details

Description Craig Robson 2016-05-30 14:51:33 UTC
Version-Release number of selected component:
setroubleshoot-server-3.3.6-1.fc24

Additional info:
reporter:       libreport-2.7.1
cmdline:        /usr/bin/python3 -Es /usr/sbin/setroubleshootd -f ''
executable:     /usr/sbin/setroubleshootd
kernel:         4.5.3-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reproducible:   The problem is reproducible
runlevel:       N 5
type:           Python3
uid:            475

Truncated backtrace:
service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set

SystemExit

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/dbus/service.py", line 647, in _message_cb
    if not isinstance(message, MethodCallMessage):
SystemError: <built-in function isinstance> returned a result with an error set

Local variables in innermost frame:
self: <setroubleshoot.server.SetroubleshootdDBusObject at /org/fedoraproject/Setroubleshootd at 0x7f01f31575f8>
message: <dbus.lowlevel.MethodCallMessage path: /org/fedoraproject/Setroubleshootd, iface: org.fedoraproject.SetroubleshootdIface, member: avc dest: org.fedoraproject.Setroubleshootd>
connection: <dbus._dbus.SystemBus (system) at 0x7f01f5dbfa40>

Potential duplicate: bug 1315860

Comment 1 Craig Robson 2016-05-30 14:51:38 UTC
Created attachment 1162840 [details]
File: backtrace

Comment 2 Craig Robson 2016-05-30 14:51:39 UTC
Created attachment 1162841 [details]
File: environ

Comment 3 Jason Birch 2016-06-01 20:37:46 UTC
*** Bug 1341842 has been marked as a duplicate of this bug. ***

Comment 4 Petr Lautrbach 2016-06-02 06:09:21 UTC

*** This bug has been marked as a duplicate of bug 1316617 ***

Comment 5 Geezus 2016-06-23 13:45:07 UTC
*** Bug 1349464 has been marked as a duplicate of this bug. ***

Comment 6 Matěj Beránek 2016-06-24 09:52:29 UTC
*** Bug 1349801 has been marked as a duplicate of this bug. ***

Comment 7 hamedraad27 2016-07-02 13:11:02 UTC
*** Bug 1352209 has been marked as a duplicate of this bug. ***

Comment 8 lc5180 2016-07-18 06:44:51 UTC
*** Bug 1357396 has been marked as a duplicate of this bug. ***

Comment 9 Adam Chasen 2016-07-25 10:49:45 UTC
*** Bug 1359719 has been marked as a duplicate of this bug. ***

Comment 10 Paulim_hed 2016-07-25 15:29:44 UTC
*** Bug 1359880 has been marked as a duplicate of this bug. ***

Comment 11 Paulim_hed 2016-07-26 23:21:21 UTC
*** Bug 1360494 has been marked as a duplicate of this bug. ***

Comment 12 Paulim_hed 2016-07-27 03:24:13 UTC
*** Bug 1360543 has been marked as a duplicate of this bug. ***

Comment 13 Paulim_hed 2016-08-02 22:15:02 UTC
*** Bug 1362703 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.