Bug 134089 - crontab -e is broken
Summary: crontab -e is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 137326 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-29 15:51 UTC by Ed Friedman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 16:10:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Friedman 2004-09-29 15:51:58 UTC
Description of problem:
crontab -e does not work

Version-Release number of selected component (if applicable):
vixie-cron-4.1-11

How reproducible:
Always

Steps to Reproduce:
1.As any user, type:    crontab -e
2.or, as root, type:    crontab -u username -e
3.
  
Actual results:
You (ed) are not allowed to use this program (crontab)
See crontab(1) for more information


Expected results:


Additional info:

Comment 1 Jason Vas Dias 2004-09-29 16:10:05 UTC
Unfortunately, the new CVS migration resulted in some fixes 
being dropped, which causes this problem.
This is now fixed in vixie-cron-4.1-16:
1. If neither /etc/cron.{allow,deny} exist, 
   ONLY root may use crontab (and now may do so!)

2. If no /etc/cron.{allow,deny} exist when the package
   is installed, the %post script will create an
   empty /etc/cron.deny file, thus allowing all users
   by default, the way the old cron used to work.

Comment 2 Jason Vas Dias 2004-10-27 16:35:15 UTC
*** Bug 137326 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.