Bug 1340891 - Ping6 command does not work with omitted (short) IPv6 address.
Ping6 command does not work with omitted (short) IPv6 address.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-30 11:01 EDT by Simeon Monov
Modified: 2016-06-01 02:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-01 02:28:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ScreenShot (214.78 KB, image/jpeg)
2016-05-30 11:01 EDT, Simeon Monov
no flags Details

  None (edit)
Description Simeon Monov 2016-05-30 11:01:44 EDT
Created attachment 1162857 [details]
ScreenShot

Description of problem:

Ping6 command does not work with omitted ("::" truncated) IPv6 address instead of the local loopback address (::1) in all other cases ping6 return "Invalid Argument" (Screenshot attached). 

Version-Release number of selected component (if applicable):

Tested on Fedora 23, 24, 25, and 25 rawhide.

How reproducible:

100% reproducible.

Steps to Reproduce:
1. In terminal type: ifconfig | grep int6
2. Copy inet6 address and ping it for example: ping fe80::20c:29ff:fee3:d432 
   
Same can be done with one command: 
 
     ping6 `ifconfig | grep inet6 | awk '{print $3; exit }'| cut -f 1 -d '/'`

This will ping your first network interface with configured IPv6 address. 

Actual results:

Ping6 command returned --> "connect: Invalid argument" Which actually is valid IPv6 address.

Expected results:

Interface should be successfully pinged and should work with all omitted IPv6 addresses.
Comment 1 Jan Synacek 2016-06-01 02:28:31 EDT
Works for me on F24 and Rawhide.

$ ping6 fe80::2ad2:44ff:fefc:15fe
PING fe80::2ad2:44ff:fefc:15fe(fe80::2ad2:44ff:fefc:15fe) 56 data bytes
64 bytes from fe80::2ad2:44ff:fefc:15fe%enp0s25: icmp_seq=1 ttl=64 time=0.134 ms
64 bytes from fe80::2ad2:44ff:fefc:15fe%enp0s25: icmp_seq=2 ttl=64 time=0.132 ms
^C

$ ping6 fe80::2ab2:bdff:feb8:e5f2
PING fe80::2ab2:bdff:feb8:e5f2(fe80::2ab2:bdff:feb8:e5f2) 56 data bytes
64 bytes from fe80::2ab2:bdff:feb8:e5f2%wlp3s0: icmp_seq=1 ttl=64 time=0.097 ms
64 bytes from fe80::2ab2:bdff:feb8:e5f2%wlp3s0: icmp_seq=2 ttl=64 time=0.134 ms
^C

$ rpm -q iputils
iputils-20160308-2.fc24.x86_64

Note You need to log in before you can comment on or make changes to this bug.