Bug 1340916 - cluster OSD expand is not working correctly
Summary: cluster OSD expand is not working correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 2
Assignee: Nishanth Thomas
QA Contact: Lubos Trilety
URL:
Whiteboard:
: 1342069 (view as bug list)
Depends On:
Blocks: Console-2-Feature-Freeze Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-30 16:37 UTC by Lubos Trilety
Modified: 2016-08-23 19:52 UTC (History)
3 users (show)

Fixed In Version: rhscon-core-0.0.26-1.el7scon.x86_64 rhscon-ceph-0.0.26-1.el7scon.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
cluster OSDs (97.82 KB, image/png)
2016-05-30 16:37 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-05-30 16:37:45 UTC
Created attachment 1162914 [details]
cluster OSDs

Description of problem:
Cluster can be expanded but many times added hosts OSDs are down by UI while 'ceph status' is showing those OSDs as up. Moreover those OSDs have no storage profile or more precisely their storage profile has no name in UI.
After skyring service restart the OSD, which was down, is missing in the list of OSDs.
In mongodb in storage_nodes collection all disk are listed with correct storage profile, but in there's a bad info in storage_logical_units collection.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.21-1.el7scon.x86_64
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create cluster
2. Expand cluster with OSD host
3.

Actual results:
Some of OSDs on the host are down, all of them has no storage profile.

Expected results:
All expanded OSDs has correct state and storage profile.

Additional info:
attached screenshot is after skyring service restart

Comment 1 Nishanth Thomas 2016-06-17 11:22:48 UTC
*** Bug 1342069 has been marked as a duplicate of this bug. ***

Comment 2 Lubos Trilety 2016-07-28 14:47:49 UTC
Tested on:
rhscon-ceph-0.0.36-1.el7scon.x86_64
rhscon-core-selinux-0.0.36-1.el7scon.noarch
rhscon-core-0.0.36-1.el7scon.x86_64
rhscon-ui-0.0.50-1.el7scon.noarch

Comment 4 errata-xmlrpc 2016-08-23 19:52:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.