Bug 134094 - Missing USB mass storage multilun device on whitelist: Power Quotient International USB Mass Storage Device
Missing USB mass storage multilun device on whitelist: Power Quotient Interna...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-29 12:21 EDT by Kyrre Ness Sjøbæk
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:17:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-09-29 12:21:49 EDT
Description of problem:
I (and i know many others as well - they are quite common) have a
multiple-card USB card reader, which i beleive is a multi-LUN device.
Only problem is that its not on the whitelist, according to Jef Spaleta.

Here is the output of lsusb -v he said you needed:

[root@localhost ~]# lsusb -v

Bus 001 Device 003: ID 3538:0015 Power Quotient International Co., Ltd
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x3538 Power Quotient International Co., Ltd
  idProduct          0x0015
  bcdDevice            0.12
  iManufacturer           1 GENERIC
  iProduct                2 USB Mass Storage Device
  iSerial                 3 ABCD1234567B
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          4 CONFIGURATION
    bmAttributes         0x80
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              5 INTERFACE 0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0008  bytes 8 once
        bInterval              10
  Language IDs: (length=4)
     0409 English(US)

Bus 001 Device 001: ID 0000:0000
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x0000
  idProduct          0x0000
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.8-1.541 uhci_hcd
  iProduct                2 UHCI Host Controller
  iSerial                 1 0000:00:14.2
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xc0
      Self Powered
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0002  bytes 2 once
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             2
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
  bPwrOn2PwrGood        1 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0x00
  PortPwrCtrlMask    0x00
  Language IDs: (length=4)
     0409 English(US)


Version-Release number of selected component (if applicable):

kernel-2.6.8-1.541

How reproducible:
Every time. Only first device (CF slot) accessable

Steps to Reproduce:
1. Plug in one of those card-readers
2. Only first slot accessable
3.
  
Actual results:
Only CF slot accessable

Expected results:
All slots should be mountable

Additional info:
Comment 1 Kyrre Ness Sjøbæk 2004-10-14 16:31:55 EDT
what is current status of this bug?
Comment 2 Dave Jones 2004-10-30 11:18:02 EDT
please include the scsi messages from 'dmesg'
Comment 3 Kyrre Ness Sjøbæk 2004-10-31 13:51:15 EST
snd_sbawe: Unknown parameter `'
pnp: Device 00:01.00 activated.
pnp: Device 00:01.02 activated.
usb 1-2: new full speed USB device using address 4
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: GENERIC   Model: Card Reader   CF  Rev: v26F
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0,  type 0
USB Mass Storage device found at 4
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
updfstab: Using deprecated /dev/sg mechanism instead of SG_IO on the
actual device

that should be it (i know the sb_awe thing has nothing to do with it,
the pnp stuff i don't know, but ill just include it to be shure)

This is from an FC2 (uname -a: Linux kyrre 2.6.8-1.521 #1 Mon Aug 16
09:01:18 EDT 2004 i686 i686 i386 GNU/Linux) machine, hope that is okay.
Comment 4 Kyrre Ness Sjøbæk 2004-11-27 16:26:33 EST
http://www.pqi.com.tw/ENG/product-CR.htm#07

A website describing the thing.
Comment 5 Dave Jones 2004-12-08 23:59:49 EST
fixed in cvs, will be in next build.
Comment 6 Kyrre Ness Sjøbæk 2004-12-09 13:24:31 EST
What shall i say? Great work! Thanks a lot! :D
Comment 7 Fritz Whittington 2004-12-22 14:00:28 EST
On or about 2004-12-22 04:45, Colin Charles whipped out a trusty #2
pencil and scribbled:

>On Mon, 2004-12-20 at 14:53 -0600, Fritz Whittington wrote:
>
>>adding max_scsi_luns=6 to the end of the boot entry in grub.conf.
>>adding options scsc_mod max_scsi_luns=6 to /etc/modprobe.conf
>>After doing modinfo scsi_mod, I note the option now seems to be
>>max_luns
>>instead of max_scsi_luns.  Changed grub.conf and modprobe.conf
>>appropriately.  No good.  (Yes, I did reboot.)
>>
>>Is this a bug in FC3, or has anyone else got it working in FC3?
>
>
>It probably needs to be whitelisted - file a bug under the kernel, with
>appropriate message from dmesg or /var/log/messages in the bug
>
>https://bugzilla.redhat.com/beta/
>
>There are other bugs similar to this, if you need to know the exact
>format for the bug report
>
I found:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134094
with:
Additional Comment #5 From Dave Jones on 2004-12-08 23:59 -------

fixed in cvs, will be in next build.

although it's not clear what he is going to fix. 

1)  Neither device is on the whitelist, BUT, each device will work
with the "first" card slot.

2)  The cards are:
# lsusb
Bus 001 Device 002: ID 0aec:3260 Neodio Technologies Corp.
Bus 001 Device 001: ID 0000:0000
and
# lsusb
Bus 001 Device 003: ID 0483:1307 SGS Thomson Microelectronics Cytronix
6in1 card reader
Bus 001 Device 001: ID 0000:0000

3)  As a work-around, I re-compiled the kernel (2.6.9-1.681_FC3) and
checked the box to "probe all LUNS", even though xconfig in that area
has a note that this can be left unchecked and over-ridden by parms in
grub and/or modprobe.conf.  THIS WORKS!  Fortunately, none of my other
SCSI devices gets broken by it. 

So, IMHO, what's broken is the "over-ride" mechanism, or the
documentation (over-ride isn't intended to work if device not on
whitelist?). 


-- 
Fritz Whittington
TI Alum - http://www.tialumni.org
Comment 8 Dave Jones 2004-12-22 15:30:21 EST
the max_luns module parameter works fine for me with multiple
different card readers.  Can you paste the output of dmesg which looks
something like this..

scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: GENERIC   Model: Card Reader   CF  Rev: v26F
  Type:   Direct-Access                      ANSI SCSI revision: 02

Could be your card is slightly different, and needs whitelisting too.
(Still doesnt explain why max_luns doesnt work for you though).
Comment 9 chris roddy 2005-01-14 20:38:42 EST
i've got another Neodio Technologies Corp. multi-card reader.
slightly different device, same problem.

i set "options scsi_mod max_luns=8" and everything works as expected.
i'd be delirious with joy if this could be patched.

<3,

cmr


here are the pertinent bits from lsusb -v:


Bus 005 Device 002: ID 0aec:3050 Neodio Technologies Corp. 
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        16
  idVendor           0x0aec Neodio Technologies Corp.
  idProduct          0x3050 
  bcdDevice            1.00
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
cannot get config descriptor 0, Connection timed out (110)

Bus 005 Device 001: ID 0000:0000  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 Unused
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x0000 
  idProduct          0x0000 
  bcdDevice            2.06
  iManufacturer           3 Linux 2.6.10-1.737_FC3 ohci_hcd
  iProduct                2 OHCI Host Controller
  iSerial                 1 0000:00:02.3
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           25
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xc0
      Self Powered
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 Unused
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0002  bytes 2 once
        bInterval             255
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             3
  wHubCharacteristic 0x0002
    No power switching (usb 1.0)
    Ganged overcurrent protection
  bPwrOn2PwrGood        1 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0x00
  PortPwrCtrlMask    0x00 
  Language IDs: (length=4)
     0409 English(US)

Comment 10 Dave Jones 2005-01-15 00:11:44 EST
see comment #8
(the bit about dmesg)

Note You need to log in before you can comment on or make changes to this bug.