Bug 134098 - Combobox default selection does not work when LANG set
Combobox default selection does not work when LANG set
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openmotif21 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 12:32 EDT by Greg Marsden
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 09:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Greg Marsden 2004-09-29 12:32:55 EDT
There is a problem with TK/openmotif on Redhat 3.0 only where the
poplists (also called combobox) are not updated properly.

 clicking on the 'down arrow' in the poplist reveals that the poplist
does have the correct entries, it is just that they are not selected as
they
should. Similar problem with poplists can be observed when invoking the
'Program Unit' editor which has 4 of these poplists.

Another example in Forms builder would be in the use of the PL/SQL editor
which contains also 4 poplists that are not initialized properly. The
poplist
is populated correctly as seen by clicking the 'down' arrow in
poplist, but
the textfield does not display the current selection as it should.

This only happens on Redhat 3.0 and is not observed on Redhat AS 2.1.

How to reproduce:
-----------------
There are many ways to reproduce the problem. In general, the poplists or
combobox of any application that uses tk/openmotif on RH 3.0 machine
has the
same problems.


The problem seems to be hapening on RH 3.0 system only with LANG
variable is default set to en_US.UTF-8. 

Workaround: unset LANG
Comment 1 Thomas Woerner 2004-10-04 11:05:31 EDT
Which OpenMotif version is this?

Do you have a testcase?
Comment 2 Greg Marsden 2004-10-04 18:29:45 EDT
openmotif21-2.1.30-8

Current testcase involves Oracle...
Comment 3 Thomas Woerner 2006-08-01 08:34:28 EDT
Assigning to openmotif21.
Comment 4 Thomas Woerner 2007-07-23 07:50:33 EDT
The test case is needed to reproduce the problem.
Comment 5 Thomas Woerner 2007-07-24 09:02:39 EDT
Closing as WINTFIX, because there is no way to reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.