Bug 1341044 - Error infos flush the Virtual machines page repeatly
Summary: Error infos flush the Virtual machines page repeatly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.0.0-rc3
: 4.18.4
Assignee: Marek Libra
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 07:16 UTC by wanghui
Modified: 2016-08-04 13:26 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 13:26:59 UTC
oVirt Team: Virt
rule-engine: ovirt-4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
gklein: testing_ack+


Attachments (Terms of Use)
Screenshot for error infos (76.46 KB, image/png)
2016-05-31 07:16 UTC, wanghui
no flags Details
sosreport (5.70 MB, application/x-xz)
2016-05-31 07:17 UTC, wanghui
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58421 0 None None None 2016-06-01 08:58:08 UTC

Description wanghui 2016-05-31 07:16:44 UTC
Created attachment 1163053 [details]
Screenshot for error infos

Description of problem:
The error infos flush the virtual machines page repeatly.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-4.0-20160527.0.x86_64
imgbased-0.7.0-0.1.el7ev.noarch
cockpit-0.103-1.el7.x86_64
cockpit-ovirt-dashboard-0.10.1-0.0.1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install NGN
2. Click oVirt -> Virtual Machines page

Actual results:
1. After step2, the error infos flush the virtual machine page repeatly.

Expected results:
1. It should provide a better way to show those error infos.

Additional info:

Comment 1 wanghui 2016-05-31 07:17:35 UTC
Created attachment 1163054 [details]
sosreport

Comment 2 Marek Libra 2016-05-31 14:48:18 UTC
The error from screenshot is produced when connection to VDSM can't be established.

Please check if you passed the Hosted Engine Setup prior trying to manage VMs.

I just installed NGN. The error mesage is shown until there is /etc/pki/vdsm/certs/cacert.pem generated. It happens during the Hosted Engine Setup.

Comment 3 wanghui 2016-06-01 02:20:16 UTC
(In reply to Marek Libra from comment #2)
> The error from screenshot is produced when connection to VDSM can't be
> established.
> 
> Please check if you passed the Hosted Engine Setup prior trying to manage
> VMs.
> 
> I just installed NGN. The error mesage is shown until there is
> /etc/pki/vdsm/certs/cacert.pem generated. It happens during the Hosted
> Engine Setup.

Hi Marek,

If I register NGN to rhevm, the error message is gone. But my point is we should provide a better way to show those error messages instead of just let them flush the page.

Comment 4 Marek Libra 2016-06-01 09:02:22 UTC
Fix: the error messages disappears after timeout (recently 5 secs)

Comment 5 Ying Cui 2016-06-12 06:23:47 UTC
To RHEV-H NG 4.0, this bug impacts cockpit UI, we have to escalate this.
Aharon, could you please give qa_ack on this bug? Thanks.

Comment 8 Nikolai Sednev 2016-08-01 16:01:10 UTC
Works for me on these components on host:
sanlock-3.2.4-2.el7_2.x86_64
ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch
ovirt-imageio-daemon-0.3.0-0.el7ev.noarch
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.16.x86_64
mom-0.5.5-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.5.x86_64
vdsm-4.18.6-1.el7ev.x86_64
ovirt-hosted-engine-setup-2.0.1-1.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
Linux version 3.10.0-327.22.2.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Thu Jun 9 10:09:10 EDT 2016
Linux 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 9 10:09:10 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux release 7.2


Note You need to log in before you can comment on or make changes to this bug.