Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1341056 - powermock: FTBFS in rawhide
Summary: powermock: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: powermock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roman Kennke
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On: 1314239
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 07:43 UTC by Mikolaj Izdebski
Modified: 2016-06-01 18:17 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-01 18:17:02 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1314239 0 unspecified CLOSED powermock-1.6.5 is available 2021-02-22 00:41:40 UTC

Internal Links: 1314239

Description Mikolaj Izdebski 2016-05-31 07:43:07 UTC
Description of problem:
Package powermock fails to build from source in rawhide.
The reason is recent easymock update to version 3.4.
It also fails during runtime due to easymock ABI breakage.

Version-Release number of selected component (if applicable):
1.6.2-3.fc24

Steps to Reproduce:
koji build --scratch f25 powermock-1.6.2-3.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/powermock

Comment 1 Raphael Groner 2016-05-31 19:12:07 UTC
Maybe an update to v1.6.4 can be a fix.
https://github.com/jayway/powermock/wiki/EasyMock

Comment 2 Michael Simacek 2016-06-01 18:17:02 UTC
Fixed by updating.


Note You need to log in before you can comment on or make changes to this bug.