Bug 134110 - xorg keyboard repeat rate has mind of its own
xorg keyboard repeat rate has mind of its own
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-29 13:13 EDT by Chris Frey
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 15:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Frey 2004-09-29 13:13:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I recently did an up2date upgrade on xorg, and xorg.conf changed the
following keyboard config line during the upgrade:

Driver      "kbd"

It used to be:  Driver "keyboard"

With the new driver ("kbd"), all seemed fine until I held a key down
for  a couple seconds.  The rate would start off fast, but then slow down.

I tried changing this with the following command:

    xset r rate 250 30

But this did not help.

When I changed the xorg.conf setting back to Driver "keyboard", the
repeat rate worked as expected again.


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-9

How reproducible:
Always

Steps to Reproduce:
1. Start Xorg with Driver "kbd" in the keyboard configuration.


Actual Results:  Keyboard repeat rate would start out fast, then slow
down by itself.

Expected Results:  The keyboard rate should have stayed at a constant
rate.

Additional info:

Here is the entire keyboard configuration section from xorg.conf, in
the config that causes the problem:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
Comment 1 Trevor Cordes 2004-10-24 23:20:30 EDT
Similar problem here.  I upgraded FC1 -> FC2 with anaconda.  After
that the keyboard repeat worked, but it was not adjustable.  The
Preferences -> Keyboard gnome GUI had no effect at all.  Everything
had worked fine for me in FC1.

I changed Driver "kbd" to Driver "keyboard" in xorg.conf as the
original poster suggests and now everything works 100% fine again. 
Not sure what I'll lose/break by doing that however -- there must be a
reason why they switched to kbd :-)

xorg-x11-6.7.0-9
kernel-2.6.8-1.521
Comment 2 Trevor Cordes 2004-11-15 05:53:48 EST
Now I just upgraded again, this time FC2->FC3 with anaconda and now
I'm experiencing the exact same problem as the original poster and am
no longer having the problem I recently reported in FC2!  Anaconda
changed my xorg.conf line back to kbd and now the rate is correct and
the adjustments work, but I too get that weird slow-down effect.

This may only affect people who, like me, set their repeat rate very
fast.  I'd say after half a second the rate goes down by about 40%. 
It's a bit hard to perceive at first.

I just thought it was interesting how the symptoms differed between
FC2 and FC3 yet the xorg versions were the same (originally).  My xorg
is now xorg-x11-6.8.1-12.
Comment 3 Colin Murtaugh 2004-11-16 09:00:52 EST
I'm seeing this to on FC3.  I also experienced this behavior on FC2.
Comment 4 Trevor Cordes 2004-11-30 10:30:42 EST
This is getting to be a major problem and it makes no sense.

I've been using FC3 a week with Driver "kbd" and here's what happened:
1. Starts out ok, keyboard repeat rate is quite fast, as I have it set
in Gnome preferences.
2. After a while (hours) the rate will start to go down.  It's weird
but it still is fast for the first half second you hold it down and
then it gets slow.
3. After days it just goes nothing but slow.  Not even a fast first
half second!
4. Changing the gnome keyboard preferences setting has no affect at
this point.

I'm going to reboot with driver "keyboard" today and report back on
how that behaves.

Note: I am using a high-end IBM "clicky" PS2 keyboard.  It works fine
in all other respects, and fine on my Windows box.

Note: I am using a KVM switch: DLInk DKVM-4.

None of these problems ever occurred before I upgraded to FC3 (and Xorg).
Comment 5 Trevor Cordes 2004-12-02 21:46:38 EST
This is *really* getting *weird*.  I'm still using Driver "kbd" as I
forgot to switch before starting X.  I've been using it all day (10
hours) and for the entire day the repeat rate has been slow (30 cps?)
and unadjustable... EXCEPT for about 3 or 4 times where the repeat
rate was back up to my desired rate (50-60 cps? just a guess) for
about 1 second for no apparent reason.

Each time I tried to immediately figure out what I did to trigger it
but I could find no common cause.  Each time it happened I was just
typing as normal or clicking the focus on some windows.
Comment 6 Trevor Cordes 2004-12-12 23:56:59 EST
Another week another weird report.  I've been using Driver "keyboard"
this time.  For the longest time (days) it seemed ok though the speed
would vary occasionally between 100% to maybe 80% of my desired rate.

Today however, for no apparent reason, the repeat rate is definitely
doing the 100% for 1 second of holding a key then down to 10% (like
5cps) of my desired rate after that 1 second.  I've never seen it this
slow.  It's the same behaviour I've been reporting above, but much slower.

I'm waiting to see if it goes away or fixes itself (without quitting
X) and will report back.
Comment 7 Trevor Cordes 2004-12-20 17:41:59 EST
Anyone else who has this bug please report whether or not you use a
KVM and if so, what kind (brand, interface type).
Comment 8 Colin Murtaugh 2004-12-20 17:49:09 EST
I have this problem on two different computers, neither with a KVM
switch. 
Comment 9 Kristian Høgsberg 2004-12-20 17:57:44 EST
This problem should be fixed in 6.8.2 which will come out early
January.  We have RPMs of the first release candidate in rawhide now,
please try it out and see if it fixes this problem. Thanks.
Comment 10 Trevor Cordes 2004-12-20 18:00:24 EST
Thanks for the tip, I will try and get those and report back.  In the
meantime, I've just opened an xorg bugzilla entry for this as my
searching showed no listed bugs on repeat rates:

https://bugs.freedesktop.org/show_bug.cgi?id=2122
Comment 11 Trevor Cordes 2004-12-21 04:30:30 EST
I was about to install the devel test releases when the bug hit me
again and I was able to note the precise effects in much more detail
this time as it was really strange.

After using X for roughly 5 hours all of a sudden, while I was typing
but taking a quick break to think, the system acted like I was holding
down the spacebar and put about 30 spaces into my window at high
speed.  I must have freaked and hit a key and it stopped it.  I
definitely had not typed a space within a few seconds of that
happening.  AND I noticed for sure this time that right as this
happened the num lock key LED turned off!  And even though the numlock
light is off, the system still thinks numlock is on (the keys still
produce numbers)!!  Now I just tapped num lock and the light stayed
off (ie: no toggle).  I tapped it again and it went on.

And now my keyboard repeat rate is down to the stock 30cps (it feels
like).

I'm using driver "kbd" this time.
Comment 12 Kristian Høgsberg 2004-12-21 10:15:04 EST
Trevor, there is an upstream bugzilla entry for this, it's just closed:

  https://bugs.freedesktop.org/show_bug.cgi?id=1651

I marked your new bug as a duplicate of that one.

Did the upgrade help?
Comment 13 Chris Frey 2004-12-23 17:45:42 EST
I'm using a KVM.  It is a Starview, 2 port keyboard/mouse/video KVM,
from StarTech.com.   SV211K is the number on it.
Comment 14 Trevor Cordes 2004-12-23 19:04:43 EST
Yes, the upgrade appears to have fixed it (so far!).  It's been 2+
days and it hasn't acted weird yet.  (Using *-6.8.1.901)  Thanks!
Comment 15 Trevor Cordes 2004-12-28 11:16:11 EST
Nearly a week now and it's 100% perfect.  The problem is well and
truly fixed (for me at least!) in the .901 version.  Thanks all!  Out
all the bugs I've come across this one was the absolute worst to live
with!
Comment 16 Kristian Høgsberg 2005-03-14 15:15:36 EST
Hmm, seems like I forgot to close this bug.

Note You need to log in before you can comment on or make changes to this bug.