Bug 1341104 - Add cluster fails with null value in column "mac_pool_id" violates not-null constraint SQL exception
Summary: Add cluster fails with null value in column "mac_pool_id" violates not-null c...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.0.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ovirt-4.0.0-rc
: ---
Assignee: Martin Mucha
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 09:32 UTC by Yaniv Kaul
Modified: 2016-06-02 10:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-02 10:04:04 UTC
oVirt Team: Network
ykaul: ovirt-4.0.0?
rule-engine: blocker?
rule-engine: planning_ack+
danken: devel_ack+
ykaul: testing_ack?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58312 0 None None None 2016-05-31 12:27:45 UTC
oVirt gerrit 58328 0 None None None 2016-05-31 12:27:17 UTC

Description Yaniv Kaul 2016-05-31 09:32:24 UTC
Description of problem:
While trying to add cluster, it fails with:
2016-05-31 05:24:01,910 INFO  [org.ovirt.engine.core.bll.AddClusterCommand] (default task-9) [4bfc4ac7] Running command: AddClusterCommand internal: false. Entities affected :  ID: 8ef0be6e-f900-424c-a44b-48011aa0694f Type: StoragePoolAction group CREATE_CLUSTER with role type ADMIN
2016-05-31 05:24:01,918 DEBUG [org.ovirt.engine.core.dal.dbbroker.CustomSQLErrorCodeSQLExceptionTranslator] (default task-9) [4bfc4ac7] Translating SQLException with SQL state '23502', error code '0', message [ERROR: null value in column "mac_pool_id" violates not-null constraint
  Detail: Failing row contains (6ac1ac1f-16dd-4093-a4df-2c0fd88dce8a, test-cluster, null, Intel Conroe Family, 2016-05-31 05:24:01.913434-04, null, 8ef0be6e-f900-424c-a44b-48011aa0694f, 200, 3.6, t, 1, t, f, f, null, f, f, b4ed2332-a7ac-4d5f-9596-99a439cb2812, { }, f, null, t, 1, 0, null, f, f, null, null, f, , f, f, 50, t, null, null, f, null, t, t, AUTO, null, null, null).
  Where: SQL statement "INSERT INTO cluster (

Version-Release number of selected component (if applicable):
7ef46c93294e03606306b49a1fb86c54b84b2a8a

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
All logs @ http://jenkins.ovirt.org/job/ovirt_master_system-tests/67/

Comment 1 Red Hat Bugzilla Rules Engine 2016-05-31 09:32:30 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Yaniv Kaul 2016-06-02 10:04:04 UTC
Verified to be working on nightly.


Note You need to log in before you can comment on or make changes to this bug.