Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1341142 - yum update installs unsupported docker-1.9 on OSE 3.1
Summary: yum update installs unsupported docker-1.9 on OSE 3.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Alex Dellapenta
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 11:01 UTC by Takayoshi Kimura
Modified: 2019-11-14 08:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 18:53:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1324130 0 high CLOSED Latest RHEL repo packages conflict with latest 3.1.* RPMs due to Docker dependencies 2021-02-22 00:41:40 UTC

Description Takayoshi Kimura 2016-05-31 11:01:57 UTC
Description of problem:

"yum update" installs unsupported docker-1.9 on OSE 3.1.

In 3.1.1.6-4 we introduced dependency to keep docker-1.8.2 but it's removed in 3.1.1.6-6 for the other issue and reveals "yum update" issue.

Version-Release number of selected component (if applicable):

OSE 3.1

How reproducible:

Always

Steps to Reproduce:
1. yum update
2.
3.

Actual results:

"yum update" installs unsupported docker-1.9 on OSE 3.1

Expected results:

"yum update" should not make the system an unsupported status and it would be great if we have a protection

Additional info:

Are OpenShift Enterprise 3.1 and Docker 1.9 compatible? 
https://access.redhat.com/solutions/2214221

Workaround is described in the article:

OpenShift 3.1 Error docker conflicts with atomic-openshift-3.1.1.6-4 
https://access.redhat.com/solutions/2217391

Comment 1 Takayoshi Kimura 2016-06-03 00:36:46 UTC
Created separated "downgrade" workaround article since the previous one depends on a particular docker version:

How to downgrade docker-1.9.1 to docker-1.8.2 
https://access.redhat.com/solutions/2347521

Comment 4 Alex Dellapenta 2016-07-22 19:11:50 UTC
The OSE 3.1 Installation and Configuration guide was updated. In the System Requirements section of the Prerequisites topic, there is a Note about the 1.8.2 / 1.9 issue and a link to a KBase which was updated to handle the downgrade steps if needed:

https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html#system-requirements

https://access.redhat.com/solutions/2214221

The "Installing Docker" subsection in the same topic got a similar Note added as well, with the same KBase link:

https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html#installing-docker

Comment 5 Takayoshi Kimura 2016-07-25 02:47:41 UTC
Could you clarify this issue is actually fixed or not. It sounds like "Won't fix but doc improved". Is OSE 3.1 customers safe to perform yum update? Did we add any caution about "yum update" in the doc?

> Description of problem:
> 
> "yum update" installs unsupported docker-1.9 on OSE 3.1.
> 
> In 3.1.1.6-4 we introduced dependency to keep docker-1.8.2 but it's removed in 3.1.1.6-6 for the other issue and reveals "yum update" issue.
> 
> Expected results:
> 
> "yum update" should not make the system an unsupported status and it would be great if we have a protection

Comment 6 Alex Dellapenta 2016-07-25 18:39:03 UTC
In the "Installing Docker" section:

https://docs.openshift.com/enterprise/3.1/install_config/install/prerequisites.html#installing-docker

There is an "Important" box that warns about Docker 1.9 support and links to the KBase. The KBase provides content that as long as you're on the latest atomic-openshift-utils package (which the reader should already be by that point in the Prerequisites doc), the installer will not automatically install Docker 1.9, and will print an error message.

The KBase also provides instructions on setting an exclude in yum.conf, preventing manual yum updates to 1.9.

And in the System Requirements topic, the "Important" box also includes:

"See the Red Hat Knowledgebase for details. Follow this topic to ensure you have the correct version of Docker installed on your hosts before installing or upgrading to OSE 3.1."

Do you feel that satisfies the BZ? Or do you feel the "Important" box in "Installing Docker" should more obviously state that the KBase provides these instructions?

Comment 7 Takayoshi Kimura 2016-07-26 00:44:27 UTC
I would clearly state that the "yum update" makes the system unsupported status in addition to the knowledge article link. In general users assume "yum update" is safe thing.

The key thing of this issue is "yum update", not the installation phase issue but maintenance.

Comment 8 Alex Dellapenta 2016-07-28 21:31:03 UTC
(In reply to Takayoshi Kimura from comment #7)
> I would clearly state that the "yum update" makes the system unsupported
> status in addition to the knowledge article link. In general users assume
> "yum update" is safe thing.
> 
> The key thing of this issue is "yum update", not the installation phase
> issue but maintenance.

Thanks, I'm re-opening this to add some clarity. I will keep you updated.

Comment 10 Takayoshi Kimura 2016-08-08 00:40:36 UTC
Looks good to me.

Comment 11 Alex Dellapenta 2016-08-16 18:53:54 UTC
Changes were published last week. See Revision History here:

https://docs.openshift.com/enterprise/3.1/welcome/revhistory_full.html#mon-aug-08-2016


Note You need to log in before you can comment on or make changes to this bug.