Bug 1341157 - wrong quota description in pool list
Summary: wrong quota description in pool list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-31 11:41 UTC by Martin Kudlej
Modified: 2016-08-23 19:52 UTC (History)
4 users (show)

Fixed In Version: rhscon-ui-0.0.43-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
wrong quota description (11.78 KB, image/png)
2016-05-31 11:41 UTC, Martin Kudlej
no flags Details
quota issue (341.39 KB, image/png)
2016-06-14 12:58 UTC, Nishanth Thomas
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-05-31 11:41:34 UTC
Created attachment 1163182 [details]
wrong quota description

Description of problem:
There is wrong quota description in pool list, please see attachment.

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-15.el7scon.noarch
ceph-installer-1.0.11-1.el7scon.noarch
rhscon-ceph-0.0.18-1.el7scon.x86_64
rhscon-core-0.0.19-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. create cluster
2. create pool with quotas
3. check pool list

Actual results:
There is wrong quota description in pool list.

Expected results:
All quota descriptions are correct.

Comment 1 Nishanth Thomas 2016-06-14 12:58:05 UTC
Created attachment 1167860 [details]
quota issue

Comment 2 Nishanth Thomas 2016-06-14 12:59:36 UTC
Two issues here
1. If only one quota param is specified, a ',' added
2. quota % is not properly stored in DB, its a big number. Also displayed in UI as infinity

Comment 3 Shubhendu Tripathi 2016-06-15 08:58:50 UTC
The REST api expects quota_max_objects to be an int value and quota_max_bytes as an uint value. As they are sent in options attribute of request, valid int and uint should be sent as below 

options: {"quota_max_objects": "<an int>", "quota_max_bytes": "<a big int>"}

There is no change required in backend API for this BZ and we need to fix in UI only.

Comment 5 Martin Kudlej 2016-07-08 12:01:19 UTC
Tested with
ceph-ansible-1.0.5-23.el7scon.noarch
ceph-installer-1.0.12-3.el7scon.noarch
rhscon-ceph-0.0.29-1.el7scon.x86_64
rhscon-core-0.0.29-1.el7scon.x86_64
rhscon-core-selinux-0.0.29-1.el7scon.noarch
rhscon-ui-0.0.43-1.el7scon.noarch
and it works. -->Verified

Comment 7 errata-xmlrpc 2016-08-23 19:52:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.