Bug 1341162 - [SR-IOV] - Specific networks list in the edit VFs dialog(in the PF) is out of the dialog range in case of multiple networks in the DC
Summary: [SR-IOV] - Specific networks list in the edit VFs dialog(in the PF) is out of...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.1.0.2
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.1.0-beta
: 4.1.0.2
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 11:58 UTC by Michael Burman
Modified: 2017-02-01 14:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:41:39 UTC
oVirt Team: Network
rule-engine: ovirt-4.1+
rule-engine: blocker+


Attachments (Terms of Use)
screenshot (113.56 KB, image/png)
2016-05-31 11:58 UTC, Michael Burman
no flags Details
screenshot_3_6 (148.96 KB, image/png)
2016-06-01 14:17 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 68524 0 master MERGED webadmin: Correcting height in VfsConfigPopupView. 2016-12-20 18:53:39 UTC
oVirt gerrit 68857 0 ovirt-engine-4.1 MERGED webadmin: Correcting height in VfsConfigPopupView. 2016-12-20 21:10:38 UTC

Description Michael Burman 2016-05-31 11:58:04 UTC
Created attachment 1163194 [details]
screenshot

Description of problem:
[SR-IOV] - Specific networks list in the edit VFs dialog(in the PF) is out of the dialog range in case of multiple networks in the DC. 

If we have multiple networks in the DC(more then 13) and we want to edit the VF's allowed networks, the list of the networks is out of the dialog window range and it's looks pretty bad. 
And there is one network that can't be chosen(can't check the checkbox), the network that is in the end of the dialog's range(in one line with the 'OK" button).   

Version-Release number of selected component (if applicable):
4.1.0-0.0.master.20160529171307.git359707b.el7.centos

How reproducible:
100

Steps to Reproduce:
1. Add sr-iov capable host to rhev 4.0
2. Create 15 networks 
3. Open setup networks and edit one of the PFs(pencil), select 'Specific networks' and try to check the last network in the list.

Actual results:
List is out of the range, looks bad.
Can't check the last network in the list(the 15' one)

Expected results:
There should be scrolling for the networks list in case of multiple networks in the DC

Comment 1 Yaniv Lavi 2016-06-01 09:49:12 UTC
Does this happen in 3.6?

Comment 2 Michael Burman 2016-06-01 14:17:12 UTC
No, on 3.6 we have a scrolling

Comment 3 Michael Burman 2016-06-01 14:17:55 UTC
Created attachment 1163699 [details]
screenshot_3_6

Comment 4 Dan Kenigsberg 2016-06-02 10:37:40 UTC
Alexander, was it triggered by your recent UI changes?

Comment 5 Red Hat Bugzilla Rules Engine 2016-06-02 10:37:45 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 6 Alexander Wels 2016-06-02 12:35:38 UTC
Potentially,

I changed the way the scrolling works in the dialogs, so this might be an unintended side effect.

Comment 7 Dan Kenigsberg 2016-06-05 07:05:06 UTC
Yaniv, please note that this issue is seen on 4.1.0-0.0.master.20160529171307.git359707b.el7.centos not on 4.0 branch. Please set the target milestone accordingly.

Comment 8 Michael Burman 2016-07-27 11:06:35 UTC
(In reply to Dan Kenigsberg from comment #7)
> Yaniv, please note that this issue is seen on
> 4.1.0-0.0.master.20160529171307.git359707b.el7.centos not on 4.0 branch.
> Please set the target milestone accordingly.

This issue is seen on 4.0.2

Comment 9 Dan Kenigsberg 2016-07-27 12:03:38 UTC
mburman, your recent comment is not clear. Which is the precise earliest version where this reproduces?

Comment 10 Alexander Wels 2016-07-27 12:24:45 UTC
Dan the problem probably appeared with the release of 4.0 upstream. I changed the way scroll bars work and I guess some of the dialogs depended on the broken behavior I fixed. The solution is to simply wrap the outer container in a ScrollPanel and it will be fine.

Comment 11 Michael Burman 2016-07-27 12:43:54 UTC
(In reply to Dan Kenigsberg from comment #9)
> mburman, your recent comment is not clear. Which is the precise earliest
> version where this reproduces?

It is very clear) 
This bug is relevant for 4.0.2
It reproduced on all the 4.0.z versions.

Comment 12 Michael Burman 2016-12-26 07:42:07 UTC
Verified on - 4.1.0-0.3.beta2.el7


Note You need to log in before you can comment on or make changes to this bug.