Bug 1341264 - Latest content isos are not working with sat 6
Summary: Latest content isos are not working with sat 6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Other
Version: 6.1.8
Hardware: x86_64
OS: Linux
urgent
urgent vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1344369 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 15:23 UTC by Chris Roberts
Modified: 2019-11-14 08:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 12:33:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Roberts 2016-05-31 15:23:18 UTC
There is a customer case that came in where a customer is using the latest content isos on the customer portal.

In the satellite when trying to enable a repo we are getting the following error:

Production.log:

<snip>

2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-optional-rpms__7Server__x86_64/listing not found
2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-rh-common-rpms__7Server__x86_64/listing not found
2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-rhceph-1_DOT_3-tools-rpms__7Server__x86_64/listing not found
2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-rpms__7Server__x86_64/listing not found
2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-satellite-tools-6_DOT_1-rpms__x86_64/listing not found
2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-supplementary-rpms__7Server__x86_64/listing not found
2016-05-30 13:23:13 [E] CDN loading error: http://disconnected.usersys.redhat.com:80/pub/sat-import/content/dist/rhel/server/7/rhel-7-server-thirdparty-oracle-java-rpms__7Server__x86_64/listing not found

</snip>

When looking at the isos on the system we only see 1 listing file at the top level but not within the repos themselves which would explain the error:

[root@disconnected mnt]# ll -R | grep -i listing | wc -l
1

Here is the ISOS from 3-16 when I went out to Kohls which have the listing files correctly:

chrobert@beowulf:/mnt$ ll -R | grep -i listing | wc -l
13

chrobert@beowulf:/mnt$ tree -fi | grep listing
./content/dist/listing
./content/dist/rhel/listing
./content/dist/rhel/server/7/7Server/listing
./content/dist/rhel/server/7/7Server/x86_64/extras/listing
./content/dist/rhel/server/7/7Server/x86_64/listing
./content/dist/rhel/server/7/7Server/x86_64/rh-common/listing
./content/dist/rhel/server/7/7Server/x86_64/sat-tools/6.1/listing
./content/dist/rhel/server/7/7Server/x86_64/sat-tools/listing
./content/dist/rhel/server/7/7Server/x86_64/supplementary/listing
./content/dist/rhel/server/7/listing
./content/dist/rhel/server/listing
./content/listing
./listing

Comment 2 Bryan Kearney 2016-06-10 15:24:57 UTC
*** Bug 1344369 has been marked as a duplicate of this bug. ***

Comment 4 Bryan Kearney 2016-06-16 12:33:52 UTC
New ISOS have been pushed. Please download these. If you are still seeing issues, please feel free to re-open.


Note You need to log in before you can comment on or make changes to this bug.