Bug 1341305 - [abrt] abrt-addon-ccpp: abrt-action-install-debuginfo:244:<module>:AttributeError: 'TypeError' object has no attribute 'errno'
Summary: [abrt] abrt-addon-ccpp: abrt-action-install-debuginfo:244:<module>:AttributeE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matej Habrnal
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:59923ddf78651462df61973a9a5...
: 1343664 1349220 1350079 1350080 1352955 (view as bug list)
Depends On:
Blocks: 1334084
TreeView+ depends on / blocked
 
Reported: 2016-05-31 18:36 UTC by Niki Guldbrand
Modified: 2016-10-02 11:59 UTC (History)
15 users (show)

Fixed In Version: abrt-2.8.2-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-22 15:58:48 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (16.23 KB, text/plain)
2016-05-31 18:37 UTC, Niki Guldbrand
no flags Details
File: environ (67 bytes, text/plain)
2016-05-31 18:37 UTC, Niki Guldbrand
no flags Details

Description Niki Guldbrand 2016-05-31 18:36:55 UTC
Version-Release number of selected component:
abrt-addon-ccpp-2.8.0-5.fc24

Additional info:
reporter:       libreport-2.7.1
cmdline:        /usr/bin/python3 -u /usr/bin/abrt-action-install-debuginfo --ids /proc/self/fd/3 --tmpdir /var/tmp/abrt-tmp-debuginfo.kqvb0y --
executable:     /usr/bin/abrt-action-install-debuginfo
kernel:         4.5.5-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           Python3
uid:            173

Truncated backtrace:
#1 download in /usr/lib64/python3.5/site-packages/reportclient/debuginfo.py:377
#2 <module> in /usr/bin/abrt-action-install-debuginfo:242

Potential duplicate: bug 1334084

Comment 1 Niki Guldbrand 2016-05-31 18:37:03 UTC
Created attachment 1163347 [details]
File: backtrace

Comment 2 Niki Guldbrand 2016-05-31 18:37:04 UTC
Created attachment 1163348 [details]
File: environ

Comment 3 Jakub Filak 2016-06-13 08:28:20 UTC
*** Bug 1343664 has been marked as a duplicate of this bug. ***

Comment 4 Matej Habrnal 2016-06-13 11:08:19 UTC
This commit fixes the bug: https://github.com/abrt/abrt/pull/1152/commits/8f7e442c649767b34152fc0bed36d731557845f0

Comment 5 Jakub Filak 2016-06-23 05:35:20 UTC
*** Bug 1349220 has been marked as a duplicate of this bug. ***

Comment 6 Matej Habrnal 2016-06-29 08:49:05 UTC
*** Bug 1350080 has been marked as a duplicate of this bug. ***

Comment 7 Matej Habrnal 2016-06-29 08:51:05 UTC
*** Bug 1350079 has been marked as a duplicate of this bug. ***

Comment 8 Matej Habrnal 2016-07-08 07:53:14 UTC
*** Bug 1352955 has been marked as a duplicate of this bug. ***

Comment 9 jibecfed 2016-07-12 21:18:15 UTC
Similar problem has been detected:

I just say yes to download 1100Mo of data of debuginfo for creating a backtrace of gnome-builder crash (note : it told me the actual use space would be 0.0)

reporter:       libreport-2.7.1
cmdline:        /usr/bin/python3 -u /usr/bin/abrt-action-install-debuginfo --ids /proc/self/fd/3 --tmpdir /var/tmp/abrt-tmp-debuginfo.ZH0HYz --
event_log:      2016-07-12-23:09:27> (« report_uReport » terminé avec succès)
executable:     /usr/bin/abrt-action-install-debuginfo
kernel:         4.6.3-300.fc24.x86_64
package:        abrt-addon-ccpp-2.8.1-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         abrt-action-install-debuginfo:245:<module>:AttributeError: 'TypeError' object has no attribute 'errno'
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           Python3
uid:            173

Comment 10 Fedora Update System 2016-07-19 07:44:32 UTC
abrt-2.8.2-1.fc24 libreport-2.7.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-57644ed626

Comment 11 Fedora Update System 2016-07-20 01:54:13 UTC
abrt-2.8.2-1.fc24, libreport-2.7.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-57644ed626

Comment 12 Fedora Update System 2016-07-22 15:58:44 UTC
abrt-2.8.2-1.fc24, libreport-2.7.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.