Bug 1341308 (CVE-2016-4457) - CVE-2016-4457 CFME: default certificate used across all installs
Summary: CVE-2016-4457 CFME: default certificate used across all installs
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-4457
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20160531,repor...
Depends On: 1340877 1390815 1390816
Blocks: 1341311 1429637 1435396
TreeView+ depends on / blocked
 
Reported: 2016-05-31 19:00 UTC by Kurt Seifried
Modified: 2019-06-08 21:14 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
CloudForms includes a default SSL/TLS certificate for the web server. This certificate is replaced at install time. However if an attacker were able to man-in-the-middle an administrator while installing the new certificate, the attacker could get a copy of the uploaded private key allowing for future attacks.
Clone Of:
Environment:
Last Closed: 2017-08-02 19:11:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:1367 normal SHIPPED_LIVE Moderate: CFME 5.8.0 security, bug, and enhancement update 2017-05-31 18:16:03 UTC
Red Hat Product Errata RHSA-2017:1601 normal SHIPPED_LIVE Important: CFME 5.7.3 security, bug fix and enhancement update 2017-06-28 18:51:52 UTC

Description Kurt Seifried 2016-05-31 19:00:13 UTC
Šimon Lukašík of Red Hat reports:

CloudForms ships a default encryption certificate and key for the web interface.

Comment 1 Kurt Seifried 2016-05-31 19:00:17 UTC
Acknowledgments:

Name: Simon Lukasik (Red Hat)

Comment 4 errata-xmlrpc 2017-05-31 14:20:44 UTC
This issue has been addressed in the following products:

  CloudForms Management Engine 5.8

Via RHSA-2017:1367 https://access.redhat.com/errata/RHSA-2017:1367

Comment 5 errata-xmlrpc 2017-06-28 15:05:44 UTC
This issue has been addressed in the following products:

  CloudForms Management Engine 5.7

Via RHSA-2017:1601 https://access.redhat.com/errata/RHSA-2017:1601


Note You need to log in before you can comment on or make changes to this bug.