Bug 1341310 - Review Request: kubernetes-ansible - Playbook and set of roles for seting up a Kubernetes cluster onto machines
Summary: Review Request: kubernetes-ansible - Playbook and set of roles for seting up ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 19:10 UTC by Jan Chaloupka
Modified: 2016-07-15 07:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-09 23:53:28 UTC
Type: ---
lsm5: fedora-review+


Attachments (Terms of Use)

Description Jan Chaloupka 2016-05-31 19:10:57 UTC
Spec URL: https://jchaloup.fedorapeople.org/reviews/kubernetes-ansible/kubernetes-ansible.spec
SRPM URL: https://jchaloup.fedorapeople.org/reviews/kubernetes-ansible/kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc20.src.rpm
Description: Playbook and set of roles for seting up a Kubernetes cluster onto machines
Fedora Account System Username: jchaloup

Koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=14333072

rpmlint kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc20.src.rpm kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc20.noarch.rpm
kubernetes-ansible.src: W: spelling-error Summary(en_US) seting -> sting, seating, setting
kubernetes-ansible.src: W: spelling-error %description -l en_US seting -> sting, seating, setting
kubernetes-ansible.noarch: W: spelling-error Summary(en_US) seting -> sting, seating, setting
kubernetes-ansible.noarch: W: spelling-error %description -l en_US seting -> sting, seating, setting
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/opencontrail/files/ifdown-vhost 0644L /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/get_files.sh 0644L /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/opencontrail/files/ifup-vhost 0644L /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes/files/kube-gen-token.sh 0644L /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/common/kube-addons.sh 0644L /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/contiv/templates/aci_gw.j2 0644L /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/common/kube-addon-update.sh 0644L /bin/bash
2 packages and 0 specfiles checked; 7 errors, 4 warnings.

non-executable-script errors can be ignored as all those files are installed on a node by the ansible book. It does not make sense to make them executable in the rpm. There is a different logic that executes the scripts.

Comment 1 Jan Chaloupka 2016-06-13 18:10:49 UTC
@gofedbot review

Comment 2 gofed bot 2016-06-13 18:23:43 UTC
This is a review *template*. Besides handling the [ ]-marked tests you are
also supposed to fix the template before pasting into bugzilla:
- Add issues you find to the list of issues on top. If there isn't such
  a list, create one.
- Add your own remarks to the template checks.
- Add new lines marked [!] or [?] when you discover new things not
  listed by fedora-review.
- Change or remove any text in the template which is plain wrong. In this
  case you could also file a bug against fedora-review
- Remove the "[ ] Manual check required", you will not have any such lines
  in what you paste.
- Remove attachments which you deem not really useful (the rpmlint
  ones are mandatory, though)
- Remove this text



Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[ ]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[ ]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "WTFPL", "Unknown or generated", "MIT/X11 (BSD
     like)", "*No copyright* MPL (v2.0)", "ISC", "*No copyright* MIT/X11
     (BSD like)", "BSD (3 clause)", "BSD (2 clause)", "BSD (3 clause)
     MIT/X11 (BSD like)", "*No copyright* Apache (v2.0)". 6388 files have
     unknown license. Detailed output of licensecheck in /tmp/tmpCrrvnz
     /review-kubernetes-ansible/licensecheck.txt
[ ]: Package requires other packages for directories it uses.
     Note: No known owner of /usr/share/kubernetes-ansible
[ ]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/kubernetes-ansible
[ ]: Package contains no bundled libraries without FPC exception.
[ ]: Changelog in prescribed format.
[ ]: Sources contain only permissible code or content.
[ ]: Package contains desktop file if it is a GUI application.
[ ]: Development files must be in a -devel package
[ ]: Package uses nothing in %doc for runtime.
[ ]: Package consistently uses macros (instead of hard-coded directory
     names).
[ ]: Package is named according to the Package Naming Guidelines.
[ ]: Package does not generate any conflict.
[ ]: Package obeys FHS, except libexecdir and /usr/target.
[ ]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[ ]: Requires correct, justified where necessary.
[ ]: Spec file is legible and written in American English.
[ ]: Package contains systemd file(s) if in need.
[ ]: Package is not known to require an ExcludeArch tag.
[ ]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[ ]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[ ]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[ ]: Package functions as described.
[ ]: Latest version is packaged.
[ ]: Package does not include license text files separate from upstream.
[ ]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc23.noarch.rpm
          kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc23.src.rpm
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/opencontrail/files/ifdown-vhost 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes/files/kube-gen-token.sh 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/common/kube-addons.sh 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/opencontrail/files/ifup-vhost 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/get_files.sh 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/contiv/templates/aci_gw.j2 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/common/kube-addon-update.sh 644 /bin/bash
2 packages and 0 specfiles checked; 7 errors, 0 warnings.




Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/opencontrail/files/ifdown-vhost 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/get_files.sh 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/contiv/templates/aci_gw.j2 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/common/kube-addon-update.sh 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes-addons/files/common/kube-addons.sh 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/opencontrail/files/ifup-vhost 644 /bin/bash
kubernetes-ansible.noarch: E: non-executable-script /usr/share/kubernetes-ansible/roles/kubernetes/files/kube-gen-token.sh 644 /bin/bash
1 packages and 0 specfiles checked; 7 errors, 0 warnings.



Requires
--------
kubernetes-ansible (rpmlib, GLIBC filtered):
    /bin/bash



Provides
--------
kubernetes-ansible:
    kubernetes-ansible



Source checksums
----------------
https://github.com/kubernetes/contrib/archive/d65ebd50364ad56c8c1fa8359e9a70fee4d410b6/contrib-d65ebd5.tar.gz :
  CHECKSUM(SHA256) this package     : 2e735e1c458f4586b97c69803fd8fd469eadbb5a7c4a3ec89d63059721e957c2
  CHECKSUM(SHA256) upstream package : 2e735e1c458f4586b97c69803fd8fd469eadbb5a7c4a3ec89d63059721e957c2


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/home/fedora/run.py -n kubernetes-ansible
Buildroot used: fedora-23-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 4 Lokesh Mandvekar 2016-06-28 14:34:00 UTC
@gofedbot review

Comment 5 Jan Chaloupka 2016-06-28 14:34:39 UTC
@gofedbot review

Comment 6 Lokesh Mandvekar 2016-06-28 14:41:33 UTC
@gofedbot review

Comment 7 Lokesh Mandvekar 2016-06-28 15:28:38 UTC
In addition to gofedbot's review posted earlier, the updated spec accounts for file and dir ownership, license is correct and valid.

Package approved.

Comment 8 Gwyn Ciesla 2016-06-28 15:33:45 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/kubernetes-ansible

Comment 9 Fedora Update System 2016-06-28 17:28:02 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-044a93b59f

Comment 10 Fedora Update System 2016-06-28 17:28:09 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-ef27b80329

Comment 11 Fedora Update System 2016-06-28 17:28:14 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d495ee2544

Comment 12 Fedora Update System 2016-06-29 18:26:45 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d495ee2544

Comment 13 Fedora Update System 2016-06-29 21:50:15 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-ef27b80329

Comment 14 Fedora Update System 2016-06-29 22:56:10 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-044a93b59f

Comment 15 Fedora Update System 2016-07-09 23:53:25 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-07-10 05:58:02 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-07-15 07:18:08 UTC
kubernetes-ansible-0.6.0-0.1.gitd65ebd5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.