Bug 1341322
| Summary: | When running the setup on a non-interactive ssh session it fails with 'run ssh with -t option' | ||
|---|---|---|---|
| Product: | [oVirt] ovirt-hosted-engine-setup | Reporter: | David Caro <dcaroest> |
| Component: | General | Assignee: | Sandro Bonazzola <sbonazzo> |
| Status: | CLOSED DUPLICATE | QA Contact: | meital avital <mavital> |
| Severity: | unspecified | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 1.3.7.0 | CC: | bugs, didi, eedri |
| Target Milestone: | --- | Flags: | rule-engine:
planning_ack?
rule-engine: devel_ack? rule-engine: testing_ack? |
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2016-05-31 20:46:12 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | Integration | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Found the option OVEHOSTED_CORE/skipTTYCheck, trying with that one Never mind, that option did the trick *** This bug has been marked as a duplicate of bug 1324520 *** |
Description of problem: When running the hosted-engine setup using a non-interactive ssh session (as running from jenkins) it fails to run with the error: current session does not belong to lago group. [ INFO ] Stage: Initializing [ INFO ] Generating a temporary VNC password. [ INFO ] Stage: Environment setup Configuration files: ['/root/hosted-engine-deploy-answers-file.conf'] Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160531155420-932uqh.log Version: otopi-1.4.1 (otopi-1.4.1-1.el7.centos) [ ERROR ] It has been detected that this program is executed through an SSH connection without pseudo-tty allocation. Please run again ssh adding -t option [WARNING] Aborted [ INFO ] Stage: Clean up [ INFO ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160531155420.conf' [ INFO ] Stage: Pre-termination [ INFO ] Stage: Termination [ ERROR ] Hosted Engine deployment failed: this system is not reliable, please check the issue, fix and redeploy Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160531155420-932uqh.log ######################### I face this issue when trying to run the system tests with hosted engine: https://gerrit.ovirt.org/#/c/58272 Version-Release number of selected component (if applicable): ovirt-hosted-engine-setup-1.3.7.0-1.el7.centos.noarch How reproducible: Run a non-interactive hosted engine setup session from a non-interactive ssh session. Steps to Reproduce: 1. 2. 3. Actual results: Expected results: Additional info: