Bug 134139 - tail -(n any number) --quiet *.txt displays the file names
Summary: tail -(n any number) --quiet *.txt displays the file names
Status: CLOSED DUPLICATE of bug 129388
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-29 19:34 UTC by Ron Rotach
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ron Rotach 2004-09-29 19:34:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.1.4322)

Description of problem:
When I use the tail command with a combination of number of lines and 
the quiet option the file names are displayed.

quiet does work with no -n option

head seems to work correctly.

example:

tail -1 --quiet *.txt


Version-Release number of selected component (if applicable):
coreutils-5.2.1-17

How reproducible:
Always

Steps to Reproduce:
1.tail -1 --quiet *.txt
2.
3.
    

Actual Results:  [ron@PCIFedora3 test tail]$ tail -1 *.txt
==> test1.txt <==
This is test1 line 4 and last line.
 
==> test2.txt <==
This is test2 line 5 and last line.
[ron@PCIFedora3 test tail]$



Expected Results:  [ron@PCIFedora3 test tail]$ tail -1 *.txt
This is test1 line 4 and last line.
This is test2 line 5 and last line.
[ron@PCIFedora3 test tail]$



Additional info:

Comment 1 Tim Waugh 2004-09-30 08:33:50 UTC
Only minimal backwards compatibility support for non-POSIX options is
provided.

*** This bug has been marked as a duplicate of 129388 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:06:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.