Bug 1341482 - ERROR and Warning message on writing a file from mount point "null gfid for path (null)" repeated 3 times between"
Summary: ERROR and Warning message on writing a file from mount point "null gfid for p...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: 3.7.11
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1336630 1341477
Blocks: 1334664 1368608
TreeView+ depends on / blocked
 
Reported: 2016-06-01 07:38 UTC by Pranith Kumar K
Modified: 2016-08-19 23:56 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.14
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1341477
: 1368608 (view as bug list)
Environment:
Last Closed: 2016-08-02 07:24:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Pranith Kumar K 2016-06-01 07:39:34 UTC
Steps to Reproduce:
1. Create 1X3 volume with arbiter as 1 brick
2. From the mount point using fuse, dd files in a directory. (using urandom)
3. Continuous ERROR and Warning message appear in the brick logs 

Actual results:
[root@dhcp43-153 ~]# tailf /var/log/glusterfs/bricks/rhs-brick2-nfs.log 
[2016-05-17 11:04:49.001762] E [MSGID: 113091] [posix.c:179:posix_lookup] 0-nfs-posix: null gfid for path (null)
[2016-05-17 11:04:49.001812] W [MSGID: 113018] [posix.c:197:posix_lookup] 0-nfs-posix: lstat on null failed [Invalid argument]
[2016-05-17 11:04:54.915753] I [login.c:76:gf_auth] 0-auth/login: allowed user names: 66fc0b36-2c1f-4e01-b21d-729b7b8896e8
[2016-05-17 11:04:54.915795] I [MSGID: 115029] [server-handshake.c:692:server_setvolume] 0-nfs-server: accepted client from dhcp43-153.lab.eng.blr.redhat.com-2920-2016/05/17-11:04:54:481605-nfs-client-2-0-0 (version: 3.9dev)
[2016-05-17 11:04:54.931408] I [MSGID: 115036] [server.c:548:server_rpc_notify] 0-nfs-server: disconnecting connection from dhcp43-153.lab.eng.blr.redhat.com-2920-2016/05/17-11:04:54:481605-nfs-client-2-0-0
[2016-05-17 11:04:54.931462] I [MSGID: 101055] [client_t.c:415:gf_client_unref] 0-nfs-server: Shutting down connection dhcp43-153.lab.eng.blr.redhat.com-2920-2016/05/17-11:04:54:481605-nfs-client-2-0-0
The message "E [MSGID: 113091] [posix.c:179:posix_lookup] 0-nfs-posix: null gfid for path (null)" repeated 3 times between [2016-05-17 11:04:49.001762] and [2016-05-17 11:04:49.005541]
The message "W [MSGID: 113018] [posix.c:197:posix_lookup] 0-nfs-posix: lstat on null failed [Invalid argument]" repeated 3 times between [2016-05-17 11:04:49.001812] and [2016-05-17 11:04:49.005542]
[2016-05-17 11:14:50.001911] E [MSGID: 113091] [posix.c:179:posix_lookup] 0-nfs-posix: null gfid for path (null)
[2016-05-17 11:14:50.001944] W [MSGID: 113018] [posix.c:197:posix_lookup] 0-nfs-posix: lstat on null failed [Invalid argument]
The message "E [MSGID: 113091] [posix.c:179:posix_lookup] 0-nfs-posix: null gfid for path (null)" repeated 3 times between [2016-05-17 11:14:50.001911] and [2016-05-17 11:14:50.005700]
The message "W [MSGID: 113018] [posix.c:197:posix_lookup] 0-nfs-posix: lstat on null failed [Invalid argument]" repeated 3 times between [2016-05-17 11:14:50.001944] and [2016-05-17 11:14:50.005702]

Comment 2 Vijay Bellur 2016-06-01 07:41:13 UTC
REVIEW: http://review.gluster.org/14598 (features/index: Exclude gfid-type for '.', '..') posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Vijay Bellur 2016-06-02 13:30:38 UTC
REVIEW: http://review.gluster.org/14598 (features/index: Exclude gfid-type for '.', '..') posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Vijay Bellur 2016-06-15 07:13:31 UTC
REVIEW: http://review.gluster.org/14598 (features/index: Exclude gfid-type for '.', '..') posted (#3) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Vijay Bellur 2016-07-05 08:53:37 UTC
REVIEW: http://review.gluster.org/14598 (features/index: Exclude gfid-type for '.', '..') posted (#4) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Vijay Bellur 2016-07-11 04:56:39 UTC
COMMIT: http://review.gluster.org/14598 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d3a93ff7a9a8d102cc13063dec33dd652d69d719
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue May 31 21:51:22 2016 +0530

    features/index: Exclude gfid-type for '.', '..'
    
    index_get_gfid_type is assuming all names are gfids where as some of these
    entry->d_names can be '.' or '..'
    
    Thanks a lot to Nithya for RC
    
     >BUG: 1336630
     >Change-Id: I06ad688a5865ab25b4f6c8a91af8c7fb2ed62186
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/14589
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
     >Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
     >(cherry picked from commit a89a9d266c439800286f281655d67f4e362dec32)
    
    Change-Id: I2a3d13ee76846c38e965f8a98bacc8755a8debfd
    BUG: 1341482
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14598
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Oleksandr Natalenko <oleksandr@natalenko.name>

Comment 7 Kaushal 2016-08-02 07:24:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.14, please open a new bug report.

glusterfs-3.7.14 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-August/050319.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.