Bug 1341492 - QEMU on POWER does not support the PowerISA 2.07 compatibility mode
Summary: QEMU on POWER does not support the PowerISA 2.07 compatibility mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: rc
: 7.3
Assignee: Thomas Huth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1340445
Blocks: RHV4.1PPC
TreeView+ depends on / blocked
 
Reported: 2016-06-01 07:58 UTC by Thomas Huth
Modified: 2016-11-07 21:13 UTC (History)
11 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:13:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 142051 None None None 2016-06-01 08:12:12 UTC
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Thomas Huth 2016-06-01 07:58:06 UTC
Description of problem:
If a RHEL KVM guest is currently run on a POWER8NVL host, it ends up in POWER7 compatibility mode (according to /proc/cpuinfo). This happens because the guests currently do not announce support for POWER8NVL directly (see BZ 1340445 for details), and because QEMU does not support the PowerISA 2.07 compatibility mode in the "ibm,client-architecture-support" firmware call. So the guests end up in PowerISA 2.06 mode, which equals to POWER7.
While BZ 1340445 tracks the modifications to the guest kernel, this ticket here is used to track the fixes for QEMU to properly provide the PowerISA 2.07 compatibility mode for guests, too.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.6.0-4.el7.ppc64le

How reproducible:
100%

Steps to Reproduce:
1. Boot a RHEL 7.2 on a POWER8NVL KVM host
2. Check /proc/cpuinfo.

Actual results:
If /proc/cpuinfo contains POWER7, it is the wrong setting.

Expected results:
/proc/cpuinfo should say something about POWER8 instead.

Comment 2 Miroslav Rezanina 2016-06-21 07:03:55 UTC
Fix included in qemu-kvm-rhev-2.6.0-8.el7

Comment 4 Zhengtong 2016-07-06 04:30:10 UTC
Reproduced the problem with the set up as follows:
---------------------------------------------------
Host: garrison 
cpu: POWER8NVL

on host check cpu type:
[root@ibm-p8-garrison-01 ~]# cat /proc/cpuinfo 
processor	: 0
cpu		: POWER8NVL (raw), altivec supported
clock		: 4023.000000MHz
revision	: 1.0 (pvr 004c 0100)

processor	: 8
cpu		: POWER8NVL (raw), altivec supported
clock		: 4023.000000MHz
revision	: 1.0 (pvr 004c 0100)
...

qemu-kvm-rhev-2.6.0-7.el7
guest: ppc64 and ppc64le
---------------------------------------------------

Boot up the ppc64 guest , and check the cpu info
[root@dhcp71-27 ~]# cat /proc/cpuinfo 
processor	: 0
cpu		: POWER7 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)

processor	: 1
cpu		: POWER7 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)
...

It is POWER7 cpu.

Boot up the ppc64le guest ,and check the cpu info
 [root@dhcp112-244 ~]# cat /proc/cpuinfo 
processor	: 0
cpu		: POWER7 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)

processor	: 1
cpu		: POWER7 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)
...

It is POWER7 cpu

----------------------------------------------------------
Update the qemu-kvm version to qemu-kvm-rhev-2.6.0-8.el7

start ppc64 guest again. check the cpu info:
[root@dhcp71-27 ~]# cat /proc/cpuinfo 
processor	: 0
cpu		: POWER8 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)

processor	: 1
cpu		: POWER8 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)
...

start ppc64le guest again. check the cpu info:
[root@dhcp112-244 ~]# cat /proc/cpuinfo 
processor	: 0
cpu		: POWER8 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)

processor	: 1
cpu		: POWER8 (architected), altivec supported
clock		: 3259.000000MHz
revision	: 1.0 (pvr 004c 0100)
...

It is POWER8 related cpu as expected.

So this bug is verified.

Comment 6 errata-xmlrpc 2016-11-07 21:13:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.