Bug 1341504 - cluster list and task list report different state
Summary: cluster list and task list report different state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Darshan
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-01 08:17 UTC by Martin Kudlej
Modified: 2016-08-23 19:53 UTC (History)
6 users (show)

Fixed In Version: rhscon-core-0.0.28-1.el7scon.x86_64.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:53:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of cluster list and task list (41.73 KB, image/png)
2016-06-01 08:17 UTC, Martin Kudlej
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 281235 None None None 2016-07-05 06:34:32 UTC
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-06-01 08:17:35 UTC
Created attachment 1163509 [details]
screenshot of cluster list and task list

Description of problem:
As you can see on screenshot there is one task for cluster creation in task list and there is related cluster entry in cluster list where icon next to cluster name indicates that cluster creation task is in progress.
But there is another cluster which icon indicates that cluster creation task is in progress too.

I think "cluster1" icon should indicate that cluster creation task for "cluster1" has failed.

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-15.el7scon.noarch
ceph-installer-1.0.11-1.el7scon.noarch
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-core-0.0.21-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. try to create more than 1 cluster where some tasks failed
2. look at cluster list and task list at same time when some of tasks are still in progress

Actual results:
Task list shows different info for cluster tasks than icons next to cluster names in cluster list.

Expected results:
If cluster creation task has failed related cluster icon should indicate it. If cluster creation task is still in progress cluster icon will indicate it.

Comment 1 Nishanth Thomas 2016-06-03 10:49:08 UTC
Need the exact steps to reproduce this as we are not hitting this issue

Comment 2 Ju Lim 2016-06-07 19:59:00 UTC
This is related to another bug about being able to create multiple clusters at the same time.  Based on recent Bug triage discussions, it was decided for 1.0, we would support the creation of 1 cluster at a time and document the limitation.  That being said, we need to ensure tasks are accurately showing the correct status.  Potentially, this bug is no longer applicable based on recent discussions/decisions.

Comment 3 Martin Bukatovic 2016-06-08 08:12:50 UTC
(In reply to Ju Lim from comment #2)
> This is related to another bug about being able to create multiple clusters
> at the same time.

Yes, that's correct.

> Based on recent Bug triage discussions, it was decided
> for 1.0, we would support the creation of 1 cluster at a time and document
> the limitation. 

Before we call it 'decided', I would like to know what Jeff thinks about
this.

> That being said, we need to ensure tasks are accurately
> showing the correct status.

I agree. Nishanth stated that creating multiple
clusters at the same time is broken because of ceph-installer or calamari. But
in this case, the problem is definitely somewhere in RHSC 2.0.

> Potentially, this bug is no longer applicable
> based on recent discussions/decisions.

To claim this, we need the final decision and based on that, recheck the problem. It may not be applicable to multiple create cluster tasks only.

Comment 4 Nishanth Thomas 2016-06-21 13:21:18 UTC

*** This bug has been marked as a duplicate of bug 1311955 ***

Comment 5 Martin Bukatovic 2016-07-04 13:20:51 UTC
(In reply to Nishanth Thomas from comment #4)
> 
> *** This bug has been marked as a duplicate of bug 1311955 ***

Why do you think this BZ is a duplicate of BZ 1311955? The reproducers looks
different:

* in BZ 1341504 (this one), one needs to start 2 create cluster tasks
  at the same time
* in BZ 1311955 (the other one), one needs to start one create cluster task
  and make it fail

Comment 6 Martin Kudlej 2016-08-08 14:18:06 UTC
I haven't seen this for long time. If we see it again we will open it.

Comment 8 errata-xmlrpc 2016-08-23 19:53:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.